# CVE-2026-33762: go-git: Missing validation decoding Index v4 files leads to panic

> A maliciously crafted Git index file can cause a runtime panic in go-git, leading to denial of service during index parsing.

- **Severity:** Low 2.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Mar 2026
- **Updated:** 31 Mar 2026
- **Also known as:** CLEANSTART-2026-LL04438, CLEANSTART-2026-TG93279, CLEANSTART-2026-ZD82952, DEBIAN-CVE-2026-33762, GHSA-gm2x-2g9h-ccm8, GO-2026-4909, MINI-243q-qvq2-6mq6, MINI-2486-p68p-5gp6, MINI-2956-3qrx-mw79, MINI-3285-2839-mh97, MINI-329c-hf9c-6x58, MINI-3fhx-cj8x-44x7, MINI-3pmf-85qf-jq4c, MINI-3x6h-jggj-3rpw, MINI-42vm-pvp5-rwr5, MINI-4365-mq9x-jrqw, MINI-4g4r-5q6q-c42v, MINI-4g7q-3rvc-cqpc, MINI-4pw7-9v4r-c54v, MINI-54fp-78h9-925p, MINI-55qp-gr9r-gm34, MINI-5hv6-2gm5-qm5c, MINI-5rgg-c2mq-rgj8, MINI-5w42-4c5x-jf54, MINI-63mr-9467-x6vw, MINI-6426-cw8v-547f, MINI-6457-8pc8-pj57, MINI-6625-jp7j-q5x4, MINI-6mmq-wp6m-v5f3, MINI-6v83-x2m6-qrvx, MINI-6w5h-8vgx-8hfm, MINI-7f97-mxqp-mgpv, MINI-7fp2-377m-6f2g, MINI-7j88-xjq4-3v5x, MINI-7q8h-m4qv-689c, MINI-8ffr-fwhg-gj65, MINI-8gmf-j8j8-3jw7, MINI-8h62-66v8-qf5q, MINI-8vrf-3xcp-c8xm, MINI-8x23-f5f5-phpf, MINI-92jr-rwwf-cvc8, MINI-937h-q9rq-43rm, MINI-9cvx-f77h-cfh4, MINI-c9jr-579f-xvxp, MINI-cm9c-qv6h-63rv, MINI-crgq-8897-p3gv, MINI-cv2q-jj8v-qh5g, MINI-cv63-5rhp-6r36, MINI-cvf7-vr8w-4hmw, MINI-cx34-w5pm-39j8, MINI-f8gq-8r25-vm42, MINI-fh3r-3wcq-chch, MINI-fm3p-874h-mcp5, MINI-fp99-6x64-j2wx, MINI-fr98-w2q3-vgcx, MINI-g7hx-p2q7-vmpp, MINI-g8fr-vvqv-8rxq, MINI-ghf3-73q7-mmwh, MINI-gj68-ccxm-wrgr, MINI-gp5c-mvrh-jvfm, MINI-h954-hqfq-v595, MINI-h9hx-hwcj-fmm2, MINI-hg27-4w8q-8fgh, MINI-hgg7-332c-82rg, MINI-hhj8-924h-4xj9, MINI-hj9v-p45w-jq24, MINI-hqwq-qcqv-gmjw, MINI-hrrc-m783-vj3g, MINI-j3rq-g2m4-fxhw, MINI-j84m-79q2-p97m, MINI-m25p-xvjh-p36v, MINI-m56j-wxf2-rcpm, MINI-m623-9gcr-m429, MINI-m64j-r5cg-5cmq, MINI-m7wq-mg28-p3qp, MINI-mcf5-84qx-p58r, MINI-mvg8-8x47-7fr4, MINI-mx82-fpr5-mffm, MINI-p45q-76x2-p994, MINI-p8wm-5wm2-8v26, MINI-p97w-wgqm-fgqr, MINI-pf99-6x43-qv2v, MINI-phpj-h6gm-cpvq, MINI-pjf3-qpgx-gwr8, MINI-pmvc-h3wc-qj47, MINI-pphj-f63j-7353, MINI-pqvm-wp84-q6cx, MINI-pvrq-prpp-h7fr, MINI-pw2r-6rvq-jqf9, MINI-q42q-pwpg-589v, MINI-q6pc-58m3-2xx2, MINI-q7j9-692c-w74h, MINI-q88c-qqg4-f7v5, MINI-q8x5-6qf5-82xv, MINI-qffh-9vmh-2j2m, MINI-qr8g-fpjg-m75j, MINI-qrpx-mc29-x6vq, MINI-r2c8-fjj7-j5m2, MINI-rhmr-4wgr-h9xg, MINI-rj8q-6698-cmgq, MINI-rjwj-8jh5-mqx2, MINI-rr2f-w8vr-gp5w, MINI-rxw2-fj7v-8mpx, MINI-v664-55h2-vgqw, MINI-vc43-575h-mwph, MINI-vg98-2mrx-m84w, MINI-vhvq-hvqp-5mrx, MINI-vm6c-2pvq-2j5g, MINI-vp2q-fvg3-6jwx, MINI-vwr9-p82j-vr8q, MINI-w39w-h77h-8c5h, MINI-w86v-rhch-p892, MINI-w967-cxhx-pmwg, MINI-wc22-52jp-9frv, MINI-wc73-63mf-jf7h, MINI-wpcm-q63j-q45j, MINI-wv9j-j4m6-pmw5, MINI-wxqm-7q3c-m5x4, MINI-x5mm-8pv2-996h, MINI-xfh7-fmwg-6pgv, MINI-xh2p-948g-8q3w, MINI-xj84-c6xc-6p6h, MINI-xjg5-cp55-vqrr, UBUNTU-CVE-2026-33762

## What is CVE-2026-33762?

CVE-2026-33762 is a low-severity denial of service vulnerability in go-git, published on 31 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

go-git is an extensible git implementation library written in pure Go. Prior to version 5.17.1, go-git’s index decoder for format version 4 fails to validate the path name prefix length before applying it to the previously decoded path name. A maliciously crafted index file can trigger an out-of-bounds slice operation, resulting in a runtime panic during normal index parsing. This issue only affects Git index format version 4. Earlier formats (go-git supports only v2 and v3) are not vulnerable to this issue. This issue has been patched in version 5.17.1.

Weakness: CWE-129 (Improper Validation of Array Index)

## Which versions are affected by CVE-2026-33762?

5 open source packages ship an affected version, including github.com/go-git/go-git/v5, github.com/go-git/go-git and github.com/go-git/go-git/v4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/go-git/go-git/v5` | Go | All versions | 5.17.1 |
| `github.com/go-git/go-git/v5` | Go | All versions | 5.17.1 |
| `github.com/go-git/go-git/v5` | Go | All versions | 5.17.1 |
| `github.com/go-git/go-git` | Go | All versions | None |
| `github.com/go-git/go-git/v4` | Go | All versions | None |

Products: Go-Git Project Go-Git.

## How do I fix CVE-2026-33762?

Upgrade github.com/go-git/go-git/v5 to 5.17.1 or later.

## Is CVE-2026-33762 being exploited?

There is no known exploitation of CVE-2026-33762 in the wild and no public exploit code.

## Other vulnerabilities in go-git

- [CVE-2023-49569](https://insights.sbomify.com/CVE-2023-49569/): Maliciously crafted Git server replies can lead to path traversal and RCE on go-git clients (critical 9.8)
- [CVE-2025-21613](https://insights.sbomify.com/CVE-2025-21613/): go-git has an Argument Injection via the URL field (critical 9.2)
- [CVE-2025-21614](https://insights.sbomify.com/CVE-2025-21614/): go-git clients vulnerable to DoS via maliciously crafted Git server replies (high 7.5)
- [CVE-2023-49568](https://insights.sbomify.com/CVE-2023-49568/): Maliciously crafted Git server replies can cause DoS on go-git clients (high 7.5)
- [CVE-2026-45022](https://insights.sbomify.com/CVE-2026-45022/): go-git: Improper parsing of specially crafted objects may lead to inconsistent interpretation compared to upstream Git (high 7.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33762 and fix it if it is affected.

What it is: CVE-2026-33762 is a low-severity denial of service vulnerability in go-git, published on 31 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-33762 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/go-git/go-git/v5 (Go): affected all versions; fixed in 5.17.1
- github.com/go-git/go-git/v5 (Go): affected all versions; fixed in 5.17.1
- github.com/go-git/go-git/v5 (Go): affected all versions; fixed in 5.17.1
- github.com/go-git/go-git (Go): affected all versions; no fix listed
- github.com/go-git/go-git/v4 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33762/ (Markdown: https://insights.sbomify.com/CVE-2026-33762/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33762
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33762
- OSV: https://osv.dev/vulnerability/CVE-2026-33762

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33762/
Summaries are generated and may contain mistakes; the official description above is the record.
