{"answers":{"affected":"2 open source packages ship an affected version, including @fastify/middie. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-33804 in the wild and no public exploit code.","fix":"Upgrade @fastify/middie to 9.3.2 or later.","what":"CVE-2026-33804 is a high-severity authentication bypass vulnerability in @fastify/middie, published on 16 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-33804 and fix it if it is affected.\n\nWhat it is: CVE-2026-33804 is a high-severity authentication bypass vulnerability in @fastify/middie, published on 16 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-33804 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @fastify/middie (npm): affected all versions; fixed in 9.3.2\n- @fastify/middie (npm): affected all versions; fixed in 9.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-33804/ (Markdown: https://insights.sbomify.com/CVE-2026-33804/index.md)","id":"CVE-2026-33804","markdown":"https://insights.sbomify.com/CVE-2026-33804/index.md","name":"CVE-2026-33804","record":{"aliases":["GHSA-v9ww-2j6r-98q6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Fastify middleware library","requires_auth":"none","summary":"Attackers can bypass middleware authentication checks by exploiting duplicate slash handling in deprecated configurations.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"openjs","cpe":[{"product":"fastify\\/middie","vendor":"fastify"}],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-436","name":"Interpretation Conflict"}],"description":"@fastify/middie versions 9.3.1 and earlier are vulnerable to middleware bypass when the deprecated Fastify ignoreDuplicateSlashes option is enabled. The middleware path matching logic does not account for duplicate slash normalization performed by Fastify's router, allowing requests with duplicate slashes to bypass middleware authentication and authorization checks. This only affects applications using the deprecated ignoreDuplicateSlashes option. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds other than disabling the ignoreDuplicateSlashes option.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"@fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option","id":"CVE-2026-33804","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"@fastify/reply-from vulnerable to connection header abuse enabling stripping of proxy-added headers","id":"CVE-2026-33805"},"packages":[{"ecosystem":"npm","fixed":["9.3.2"],"introduced":["0"],"last_affected":[],"package":"@fastify/middie","purl":null,"source":"GHSA-v9ww-2j6r-98q6"},{"ecosystem":"npm","fixed":["9.3.2"],"introduced":["0"],"last_affected":[],"package":"@fastify/middie","purl":"pkg:npm/%40fastify/middie","source":"GHSA-v9ww-2j6r-98q6"}],"prev":{"headline":"Junos OS Evolved: A port which has been inadvertently exposed can be reached by an attacker","id":"CVE-2026-33803"},"products":["@fastify/middie"],"published":"2026-04-16","related":[{"cvss_score":9.1,"headline":"@fastify/middie vulnerable to path-scoped middleware bypass via absolute-form request target","id":"CVE-2026-85184","kev_date_added":null,"published":"2026-09-04"},{"cvss_score":9.1,"headline":"@fastify/middie vulnerable to authorization bypass via encoded slash in path parameter values","id":"CVE-2026-14198","kev_date_added":null,"published":"2026-07-01"},{"cvss_score":9.1,"headline":"@fastify/middie vulnerable to middleware authentication bypass in child plugin scopes","id":"CVE-2026-6270","kev_date_added":null,"published":"2026-04-16"},{"cvss_score":8.4,"headline":"Fastify Middie Middleware Path Bypass","id":"CVE-2026-22031","kev_date_added":null,"published":"2026-01-19"},{"cvss_score":8.2,"headline":"@fastify/middie has an improper path normalization vulnerability","id":"CVE-2026-2880","kev_date_added":null,"published":"2026-02-27"},{"cvss_score":7.5,"headline":"@fastify/middie standalone engine vulnerable to Denial of Service via malformed percent-encoded paths","id":"CVE-2026-14181","kev_date_added":null,"published":"2026-07-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-16","vendors":["@fastify/middie"]},"summary":"Attackers can bypass middleware authentication checks by exploiting duplicate slash handling in deprecated configurations.","url":"https://insights.sbomify.com/CVE-2026-33804/"}