# CVE-2026-33804: @fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option

> Attackers can bypass middleware authentication checks by exploiting duplicate slash handling in deprecated configurations.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Apr 2026
- **Updated:** 16 Apr 2026
- **Also known as:** GHSA-v9ww-2j6r-98q6

## What is CVE-2026-33804?

CVE-2026-33804 is a high-severity authentication bypass vulnerability in @fastify/middie, published on 16 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@fastify/middie versions 9.3.1 and earlier are vulnerable to middleware bypass when the deprecated Fastify ignoreDuplicateSlashes option is enabled. The middleware path matching logic does not account for duplicate slash normalization performed by Fastify's router, allowing requests with duplicate slashes to bypass middleware authentication and authorization checks. This only affects applications using the deprecated ignoreDuplicateSlashes option. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds other than disabling the ignoreDuplicateSlashes option.

Weakness: CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2026-33804?

2 open source packages ship an affected version, including @fastify/middie. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@fastify/middie` | npm | All versions | 9.3.2 |
| `@fastify/middie` | npm | All versions | 9.3.2 |

Products: Fastify Fastify\/Middie.

## How do I fix CVE-2026-33804?

Upgrade @fastify/middie to 9.3.2 or later.

## Is CVE-2026-33804 being exploited?

There is no known exploitation of CVE-2026-33804 in the wild and no public exploit code.

## Other vulnerabilities in @fastify/middie

- [CVE-2026-85184](https://insights.sbomify.com/CVE-2026-85184/): @fastify/middie vulnerable to path-scoped middleware bypass via absolute-form request target (critical 9.1)
- [CVE-2026-14198](https://insights.sbomify.com/CVE-2026-14198/): @fastify/middie vulnerable to authorization bypass via encoded slash in path parameter values (critical 9.1)
- [CVE-2026-6270](https://insights.sbomify.com/CVE-2026-6270/): @fastify/middie vulnerable to middleware authentication bypass in child plugin scopes (critical 9.1)
- [CVE-2026-22031](https://insights.sbomify.com/CVE-2026-22031/): Fastify Middie Middleware Path Bypass (high 8.4)
- [CVE-2026-2880](https://insights.sbomify.com/CVE-2026-2880/): @fastify/middie has an improper path normalization vulnerability (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33804 and fix it if it is affected.

What it is: CVE-2026-33804 is a high-severity authentication bypass vulnerability in @fastify/middie, published on 16 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33804 in the wild and no public exploit code.

Affected packages and fixed versions:
- @fastify/middie (npm): affected all versions; fixed in 9.3.2
- @fastify/middie (npm): affected all versions; fixed in 9.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33804/ (Markdown: https://insights.sbomify.com/CVE-2026-33804/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33804
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33804
- OSV: https://osv.dev/vulnerability/CVE-2026-33804

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33804/
Summaries are generated and may contain mistakes; the official description above is the record.
