# CVE-2026-33805: @fastify/reply-from vulnerable to connection header abuse enabling stripping of proxy-added headers

> Attackers can strip proxy-added security headers by abusing the Connection header, bypassing access controls in Fastify proxy libraries.

- **Severity:** Critical 9.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:L/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-gwhp-pf74-vj37

## What is CVE-2026-33805?

CVE-2026-33805 is a critical vulnerability in @fastify/reply-from @fastify/http-proxy, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@fastify/reply-from v12.6.1 and earlier and @fastify/http-proxy v11.4.3 and earlier process the client's Connection header after the proxy has added its own headers via rewriteRequestHeaders. This allows attackers to retroactively strip proxy-added headers from upstream requests by listing them in the Connection header value. Any header added by the proxy for routing, access control, or security purposes can be selectively removed by a client. @fastify/http-proxy is also affected as it delegates to @fastify/reply-from. 

Upgrade to @fastify/reply-from v12.6.2 or @fastify/http-proxy v11.4.4 or later.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests), CWE-644 (Improper Neutralization of HTTP Headers for Scripting Syntax)

## Which versions are affected by CVE-2026-33805?

4 open source packages ship an affected version, including @fastify/http-proxy and @fastify/reply-from. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@fastify/http-proxy` | npm | All versions | 11.4.4 |
| `@fastify/http-proxy` | npm | All versions | 11.4.4 |
| `@fastify/reply-from` | npm | All versions | 12.6.2 |
| `@fastify/reply-from` | npm | All versions | 12.6.2 |

Products: Fastify Fastify\/Http-Proxy, Fastify Reply-From.

## How do I fix CVE-2026-33805?

Upgrade @fastify/http-proxy to 11.4.4 or later.

## Is CVE-2026-33805 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33805 exists.

## Other vulnerabilities in @fastify/reply-from @fastify/http-proxy

- [CVE-2026-16117](https://insights.sbomify.com/CVE-2026-16117/): @fastify/http-proxy vulnerable to prefix escape via URL-encoded characters (critical 10.0)
- [CVE-2026-15631](https://insights.sbomify.com/CVE-2026-15631/): @fastify/http-proxy vulnerable to prefix escape via WebSocket path traversal (high 8.7)
- [CVE-2026-85124](https://insights.sbomify.com/CVE-2026-85124/): @fastify/http-proxy vulnerable to prefix escape via backslash dot-segments (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33805 and fix it if it is affected.

What it is: CVE-2026-33805 is a critical vulnerability in @fastify/reply-from @fastify/http-proxy, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33805 exists.

Affected packages and fixed versions:
- @fastify/http-proxy (npm): affected all versions; fixed in 11.4.4
- @fastify/http-proxy (npm): affected all versions; fixed in 11.4.4
- @fastify/reply-from (npm): affected all versions; fixed in 12.6.2
- @fastify/reply-from (npm): affected all versions; fixed in 12.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33805/ (Markdown: https://insights.sbomify.com/CVE-2026-33805/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33805
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33805
- OSV: https://osv.dev/vulnerability/CVE-2026-33805

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33805/
Summaries are generated and may contain mistakes; the official description above is the record.
