{"answers":{"affected":"2 open source packages ship an affected version, including @fastify/express. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33807 exists.","fix":"Upgrade @fastify/express to 4.0.5 or later.","what":"CVE-2026-33807 is a critical authentication bypass vulnerability in @fastify/express, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-33807 and fix it if it is affected.\n\nWhat it is: CVE-2026-33807 is a critical authentication bypass vulnerability in @fastify/express, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33807 exists.\n\nAffected packages and fixed versions:\n- @fastify/express (npm): affected all versions; fixed in 4.0.5\n- @fastify/express (npm): affected all versions; fixed in 4.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-33807/ (Markdown: https://insights.sbomify.com/CVE-2026-33807/index.md)","id":"CVE-2026-33807","markdown":"https://insights.sbomify.com/CVE-2026-33807/index.md","name":"CVE-2026-33807","record":{"aliases":["GHSA-hrwm-hgmj-7p9c"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Fastify Express adapter","requires_auth":"none","summary":"Attackers can bypass authentication and authorization controls in child plugin scopes due to a path handling bug in the Fastify Express adapter.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"openjs","cpe":[{"product":"fastify\\/express","vendor":"fastify"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-436","name":"Interpretation Conflict"}],"description":"@fastify/express v4.0.4 and earlier contains a path handling bug in the onRegister function that causes middleware paths to be doubled when inherited by child plugins. When a child plugin is registered with a prefix that matches a middleware path, the middleware path is prefixed a second time, causing it to never match incoming requests. This results in complete bypass of Express middleware security controls, including authentication, authorization, and rate limiting, for all routes defined within affected child plugin scopes. No special configuration or request crafting is required.\n\nUpgrade to @fastify/express v4.0.5 or later.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"@fastify/express vulnerable to middleware path doubling causing authentication bypass in child plugin scopes","id":"CVE-2026-33807","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"@fastify/express has a middleware authentication bypass via URL normalization gaps (duplicate slashes and semicolons)","id":"CVE-2026-33808"},"packages":[{"ecosystem":"npm","fixed":["4.0.5"],"introduced":["0"],"last_affected":[],"package":"@fastify/express","purl":null,"source":"GHSA-hrwm-hgmj-7p9c"},{"ecosystem":"npm","fixed":["4.0.5"],"introduced":["0"],"last_affected":[],"package":"@fastify/express","purl":"pkg:npm/%40fastify/express","source":"GHSA-hrwm-hgmj-7p9c"}],"prev":{"headline":"fastify vulnerable to Body Schema Validation Bypass via Leading Space in Content-Type Header","id":"CVE-2026-33806"},"products":["@fastify/express"],"published":"2026-04-15","related":[{"cvss_score":9.1,"headline":"@fastify/express vulnerable to middleware bypass via non-string mount paths in prefixed plugins","id":"CVE-2026-6556","kev_date_added":null,"published":"2026-06-30"},{"cvss_score":9.1,"headline":"@fastify/express has a middleware authentication bypass via URL normalization gaps (duplicate slashes and semicolons)","id":"CVE-2026-33808","kev_date_added":null,"published":"2026-04-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-15","vendors":["fastify"]},"summary":"Attackers can bypass authentication and authorization controls in child plugin scopes due to a path handling bug in the Fastify Express adapter.","url":"https://insights.sbomify.com/CVE-2026-33807/"}