{"answers":{"affected":"2 open source packages ship an affected version, including @fastify/express. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33808 exists.","fix":"Upgrade @fastify/express to 4.0.5 or later.","what":"CVE-2026-33808 is a critical authentication bypass vulnerability in @fastify/express, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-33808 and fix it if it is affected.\n\nWhat it is: CVE-2026-33808 is a critical authentication bypass vulnerability in @fastify/express, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33808 exists.\n\nAffected packages and fixed versions:\n- @fastify/express (npm): affected all versions; fixed in 4.0.5\n- @fastify/express (npm): affected all versions; fixed in 4.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-33808/ (Markdown: https://insights.sbomify.com/CVE-2026-33808/index.md)","id":"CVE-2026-33808","markdown":"https://insights.sbomify.com/CVE-2026-33808/index.md","name":"CVE-2026-33808","record":{"aliases":["GHSA-6hw5-45gm-fj88"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Fastify Express adapter","requires_auth":"none","summary":"An unauthenticated attacker can bypass path-scoped authentication middleware in @fastify/express by exploiting URL normalization gaps when specific router options are enabled.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"openjs","cpe":[{"product":"fastify\\/express","vendor":"fastify"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-436","name":"Interpretation Conflict"}],"description":"Impact@fastify/express v4.0.4 and earlier fails to normalize URLs before passing them to Express middleware when Fastify router normalization options are enabled. This allows complete bypass of path-scoped authentication middleware via duplicate slashes when ignoreDuplicateSlashes is enabled, or via semicolon delimiters when useSemicolonDelimiter is enabled. In both cases, Fastify router normalizes the URL and matches the route, but @fastify/express passes the original un-normalized URL to Express middleware, which fails to match and is skipped. An unauthenticated attacker can access protected routes by manipulating the URL path.\n\nPatchesUpgrade to @fastify/express v4.0.5 or later.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"@fastify/express has a middleware authentication bypass via URL normalization gaps (duplicate slashes and semicolons)","id":"CVE-2026-33808","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"OOM from malicious IFD offset in golang.org/x/image/tiff","id":"CVE-2026-33809"},"packages":[{"ecosystem":"npm","fixed":["4.0.5"],"introduced":["0"],"last_affected":[],"package":"@fastify/express","purl":null,"source":"GHSA-6hw5-45gm-fj88"},{"ecosystem":"npm","fixed":["4.0.5"],"introduced":["0"],"last_affected":[],"package":"@fastify/express","purl":"pkg:npm/%40fastify/express","source":"GHSA-6hw5-45gm-fj88"}],"prev":{"headline":"@fastify/express vulnerable to middleware path doubling causing authentication bypass in child plugin scopes","id":"CVE-2026-33807"},"products":["@fastify/express"],"published":"2026-04-15","related":[{"cvss_score":9.1,"headline":"@fastify/express vulnerable to middleware bypass via non-string mount paths in prefixed plugins","id":"CVE-2026-6556","kev_date_added":null,"published":"2026-06-30"},{"cvss_score":9.1,"headline":"@fastify/express vulnerable to middleware path doubling causing authentication bypass in child plugin scopes","id":"CVE-2026-33807","kev_date_added":null,"published":"2026-04-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-15","vendors":["fastify"]},"summary":"An unauthenticated attacker can bypass path-scoped authentication middleware in @fastify/express by exploiting URL normalization gaps when specific router options are enabled.","url":"https://insights.sbomify.com/CVE-2026-33808/"}