# CVE-2026-33808: @fastify/express has a middleware authentication bypass via URL normalization gaps (duplicate slashes and semicolons)

> An unauthenticated attacker can bypass path-scoped authentication middleware in @fastify/express by exploiting URL normalization gaps when specific router options are enabled.

- **Severity:** Critical 9.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2026
- **Updated:** 15 Apr 2026
- **Also known as:** GHSA-6hw5-45gm-fj88

## What is CVE-2026-33808?

CVE-2026-33808 is a critical authentication bypass vulnerability in @fastify/express, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Impact@fastify/express v4.0.4 and earlier fails to normalize URLs before passing them to Express middleware when Fastify router normalization options are enabled. This allows complete bypass of path-scoped authentication middleware via duplicate slashes when ignoreDuplicateSlashes is enabled, or via semicolon delimiters when useSemicolonDelimiter is enabled. In both cases, Fastify router normalizes the URL and matches the route, but @fastify/express passes the original un-normalized URL to Express middleware, which fails to match and is skipped. An unauthenticated attacker can access protected routes by manipulating the URL path.

PatchesUpgrade to @fastify/express v4.0.5 or later.

Weakness: CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2026-33808?

2 open source packages ship an affected version, including @fastify/express. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@fastify/express` | npm | All versions | 4.0.5 |
| `@fastify/express` | npm | All versions | 4.0.5 |

Products: Fastify Fastify\/Express.

## How do I fix CVE-2026-33808?

Upgrade @fastify/express to 4.0.5 or later.

## Is CVE-2026-33808 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33808 exists.

## Other vulnerabilities in @fastify/express

- [CVE-2026-6556](https://insights.sbomify.com/CVE-2026-6556/): @fastify/express vulnerable to middleware bypass via non-string mount paths in prefixed plugins (critical 9.1)
- [CVE-2026-33807](https://insights.sbomify.com/CVE-2026-33807/): @fastify/express vulnerable to middleware path doubling causing authentication bypass in child plugin scopes (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33808 and fix it if it is affected.

What it is: CVE-2026-33808 is a critical authentication bypass vulnerability in @fastify/express, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33808 exists.

Affected packages and fixed versions:
- @fastify/express (npm): affected all versions; fixed in 4.0.5
- @fastify/express (npm): affected all versions; fixed in 4.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33808/ (Markdown: https://insights.sbomify.com/CVE-2026-33808/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33808
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33808
- OSV: https://osv.dev/vulnerability/CVE-2026-33808

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33808/
Summaries are generated and may contain mistakes; the official description above is the record.
