{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-3381 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-3381 is a critical vulnerability in PMQS Compress::Raw::Zlib, published on 5 Mar 2026."},"fix_prompt":"Check this codebase for CVE-2026-3381 and fix it if it is affected.\n\nWhat it is: CVE-2026-3381 is a critical vulnerability in PMQS Compress::Raw::Zlib, published on 5 Mar 2026. \nExploitation: There is no known exploitation of CVE-2026-3381 in the wild and no public exploit code.\n\nAffected product: PMQS Compress::Raw::Zlib. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-3381/ (Markdown: https://insights.sbomify.com/CVE-2026-3381/index.md)","id":"CVE-2026-3381","markdown":"https://insights.sbomify.com/CVE-2026-3381/index.md","name":"CVE-2026-3381","record":{"aliases":["ALPINE-CVE-2026-3381","AZL-79239","AZL-79242","AZL-79245","AZL-79248","AZL-79251","AZL-79254","AZL-79257","AZL-79260","AZL-79262","AZL-79265","AZL-79268","AZL-79271","AZL-79274","AZL-79277","AZL-79280","AZL-79283","AZL-79286","AZL-79290","AZL-79293","AZL-79296","AZL-79299","AZL-79302","AZL-79304","AZL-79308","AZL-79310","AZL-79316","AZL-79326","AZL-79328","AZL-79331","AZL-79334","AZL-79337","AZL-79346","AZL-79350","AZL-79358","AZL-79362","AZL-79368","AZL-79371","AZL-79373","AZL-79377","AZL-79380","AZL-79389","AZL-79391","AZL-79395","AZL-79407","AZL-79410","AZL-79415","AZL-79418","AZL-79421","AZL-79424","AZL-79431","AZL-79437","AZL-79440","AZL-79442","AZL-79446","AZL-79449","AZL-79452","AZL-79455","AZL-79460","AZL-79467","AZL-79469","AZL-79472","AZL-79475","AZL-79478","AZL-79481","AZL-79484","AZL-79487","DEBIAN-CVE-2026-3381","GHSA-jvq4-fjjq-g6w7","UBUNTU-CVE-2026-3381","openSUSE-SU-2026:10320-1","openSUSE-SU-2026:21142-1"],"analysis":null,"analysis_generated_by":null,"assigner":"CPANSec","cpe":[{"product":"compress\\","vendor":"pmqs"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-1284","name":"Improper Validation of Specified Quantity in Input"},{"id":"CWE-1395","name":"Dependency on Vulnerable Third-Party Component"}],"description":"Compress::Raw::Zlib versions through 2.219 for Perl use potentially insecure versions of zlib.\n\nCompress::Raw::Zlib includes a copy of the zlib library. Compress::Raw::Zlib version 2.220 includes zlib 1.3.2, which addresses findings fron the 7ASecurity audit of zlib. The includes fixs for CVE-2026-27171.","ecosystems":["openSUSE:Leap 16.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Compress::Raw::Zlib versions through 2.219 for Perl use potentially insecure versions of zlib","id":"CVE-2026-3381","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2026"},"n_packages":2,"n_references":7,"next":{"headline":"ChaiScript boxed_number.hpp get_as memory corruption","id":"CVE-2026-3382"},"packages":[{"ecosystem":"openSUSE:Leap 16.0","fixed":["2.222-bp160.1.1"],"introduced":["0"],"last_affected":[],"package":"perl-Compress-Raw-Zlib","purl":"pkg:rpm/opensuse/perl-Compress-Raw-Zlib\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:21142-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.222-1.1"],"introduced":["0"],"last_affected":[],"package":"perl-Compress-Raw-Zlib","purl":"pkg:rpm/opensuse/perl-Compress-Raw-Zlib\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10320-1"}],"prev":{"headline":"Tenda F453 L7Im frmL7ImForm buffer overflow","id":"CVE-2026-3380"},"products":["Compress::Raw::Zlib"],"published":"2026-03-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-03-11","vendors":["PMQS"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-3381/"}