CVE-2026-33857 Apache HTTP Server: Off-by-one OOB reads in AJP getter functions

Medium 5.3 Published Updated

An attacker can trigger out-of-bounds reads in Apache HTTP Server's AJP module, potentially exposing memory or causing a crash.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-33857?

CVE-2026-33857 is a medium-severity memory corruption vulnerability in Apache Http Server, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Out-of-bounds Read vulnerability in mod_proxy_ajp of

Apache HTTP Server.

This issue affects Apache HTTP Server: through 2.4.66.

Users are recommended to upgrade to version 2.4.67, which fixes the issue.

Weakness: CWE-125

Which versions are affected by CVE-2026-33857?

1 open source package ship an affected version, including apache. It affects 1 product.

PackageAffectedFixed in
apache BitnamiAll versions2.4.67

Products include Apache Http Server.

How do I fix CVE-2026-33857?

Upgrade apache to 2.4.67 or later.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-33857 being exploited?

There is no known exploitation of CVE-2026-33857 in the wild and no public exploit code.

All Apache Http Server vulnerabilities

Sources

Also known as ALPINE-CVE-2026-33857, AZL-86007, BELL-CVE-2026-33857, BIT-apache-2026-33857, DEBIAN-CVE-2026-33857, GHSA-v5qg-p44g-5728 and 2 more.

Is CVE-2026-33857 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free