CVE-2026-33858 Apache Airflow: Unsafe Deserialization via Legacy Serialization Keys (__type/__var) Bypass in XCom API

High 8.8 Published Updated

Dag authors can execute arbitrary code in the webserver context by crafting malicious XCom payloads via unsafe deserialization.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-33858?

CVE-2026-33858 is a high-severity unsafe deserialization vulnerability in Apache Airflow, published on 13 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Dag Authors, who normally should not be able to execute code in the webserver context could craft XCom payload causing the webserver to execute arbitrary code. Since Dag Authors are already highly trusted, severity of this issue is Low.

Users are recommended to upgrade to Apache Airflow 3.2.0, which resolves this issue.

Weakness: CWE-502

Which versions are affected by CVE-2026-33858?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.

PackageAffectedFixed in
apache-airflow PyPIFrom 3.1.83.2.0
apache-airflow PyPIFrom 3.1.83.2.0
apache-airflow PyPIFrom 3.1.83.2.0
airflow BitnamiFrom 3.1.83.2.0

Products include Apache Airflow.

How do I fix CVE-2026-33858?

Upgrade apache-airflow to 3.2.0 or later.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2026-33858 being exploited?

There is no known exploitation of CVE-2026-33858 in the wild and no public exploit code.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2026-33858, ECHO-a0ac-41bb-a272, GHSA-mc4f-r875-v87w, MINI-97fw-3337-7rq4, PYSEC-2026-20.

Is CVE-2026-33858 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free