# CVE-2026-33858: Apache Airflow: Unsafe Deserialization via Legacy Serialization Keys (__type/__var) Bypass in XCom API

> Dag authors can execute arbitrary code in the webserver context by crafting malicious XCom payloads via unsafe deserialization.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Apr 2026
- **Updated:** 14 Apr 2026
- **Also known as:** BIT-airflow-2026-33858, ECHO-a0ac-41bb-a272, GHSA-mc4f-r875-v87w, MINI-97fw-3337-7rq4, PYSEC-2026-20

## What is CVE-2026-33858?

CVE-2026-33858 is a high-severity unsafe deserialization vulnerability in Apache Airflow, published on 13 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Dag Authors, who normally should not be able to execute code in the webserver context could craft XCom payload causing the webserver to execute arbitrary code. Since Dag Authors are already highly trusted, severity of this issue is Low.

Users are recommended to upgrade to Apache Airflow 3.2.0, which resolves this issue.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-33858?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | From 3.1.8 | 3.2.0 |
| `apache-airflow` | PyPI | From 3.1.8 | 3.2.0 |
| `apache-airflow` | PyPI | From 3.1.8 | 3.2.0 |
| `airflow` | Bitnami | From 3.1.8 | 3.2.0 |

Products: Apache Airflow.

## How do I fix CVE-2026-33858?

Upgrade apache-airflow to 3.2.0 or later.

## Is CVE-2026-33858 being exploited?

There is no known exploitation of CVE-2026-33858 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33858 and fix it if it is affected.

What it is: CVE-2026-33858 is a high-severity unsafe deserialization vulnerability in Apache Airflow, published on 13 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33858 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected from 3.1.8; fixed in 3.2.0
- apache-airflow (PyPI): affected from 3.1.8; fixed in 3.2.0
- apache-airflow (PyPI): affected from 3.1.8; fixed in 3.2.0
- airflow (Bitnami): affected from 3.1.8; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33858/ (Markdown: https://insights.sbomify.com/CVE-2026-33858/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33858
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33858
- OSV: https://osv.dev/vulnerability/CVE-2026-33858

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33858/
Summaries are generated and may contain mistakes; the official description above is the record.
