# CVE-2026-33865: Stored XSS via unsafe YAML parsing in MLflow

> An authenticated attacker can inject malicious scripts via YAML artifacts, leading to session hijacking or unauthorized actions when victims view the content.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Apr 2026
- **Updated:** 14 Apr 2026
- **Also known as:** BIT-mlflow-2026-33865, GHSA-fh64-r2vc-xvhr, PYSEC-2026-93

## What is CVE-2026-33865?

CVE-2026-33865 is a medium-severity cross-site scripting vulnerability in Lfprojects Mlflow, published on 7 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

MLflow is vulnerable to Stored Cross-Site Scripting (XSS) caused by unsafe parsing of YAML-based MLmodel artifacts in its web interface. An authenticated attacker can upload a malicious MLmodel file containing a payload that executes when another user views the artifact in the UI. This allows actions such as session hijacking or performing operations on behalf of the victim. 

This issue affects MLflow version through 3.10.1

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-33865?

4 open source packages ship an affected version, including mlflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | All versions | 3.11.1 |
| `mlflow` | PyPI | All versions | 3.11.0rc0 |
| `mlflow` | PyPI | All versions | 3.11.1 |
| `mlflow` | PyPI | All versions | 3.11.1 |

Products: Lfprojects Mlflow.

## How do I fix CVE-2026-33865?

Upgrade mlflow to a fixed version for your release line: 3.11.1 or 3.11.0rc0.

## Is CVE-2026-33865 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33865 exists.

## Other vulnerabilities in Lfprojects Mlflow

- [CVE-2026-64849](https://insights.sbomify.com/CVE-2026-64849/): MLflow Server-Side Request Forgery (critical 9.3, exploited in the wild)
- [CVE-2025-15379](https://insights.sbomify.com/CVE-2025-15379/): Command Injection in mlflow/mlflow (critical 10.0)
- [CVE-2024-0520](https://insights.sbomify.com/CVE-2024-0520/): Remote Code Execution due to Full Controlled File Write in mlflow/mlflow (critical 10.0)
- [CVE-2023-6977](https://insights.sbomify.com/CVE-2023-6977/): Path Traversal: '\..\filename' (critical 10.0)
- [CVE-2023-6709](https://insights.sbomify.com/CVE-2023-6709/): Improper Neutralization of Special Elements Used in a Template Engine in mlflow/mlflow (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33865 and fix it if it is affected.

What it is: CVE-2026-33865 is a medium-severity cross-site scripting vulnerability in Lfprojects Mlflow, published on 7 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33865 exists.

Affected packages and fixed versions:
- mlflow (Bitnami): affected all versions; fixed in 3.11.1
- mlflow (PyPI): affected all versions; fixed in 3.11.0rc0
- mlflow (PyPI): affected all versions; fixed in 3.11.1
- mlflow (PyPI): affected all versions; fixed in 3.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33865/ (Markdown: https://insights.sbomify.com/CVE-2026-33865/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33865
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33865
- OSV: https://osv.dev/vulnerability/CVE-2026-33865

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33865/
Summaries are generated and may contain mistakes; the official description above is the record.
