# CVE-2026-33875: Authenticator Vulnerable to Authentication Flow Hijack


- **Severity:** Critical 9.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 27 Mar 2026
- **Updated:** 3 Apr 2026
- **Also known as:** GHSA-qg87-cf56-2rmr

## What is CVE-2026-33875?

CVE-2026-33875 is a critical vulnerability in gematik app-Authenticator, published on 27 Mar 2026. 

### Official description

Gematik Authenticator securely authenticates users for login to digital health applications. Versions prior to 4.16.0 are vulnerable to authentication flow hijacking, potentially allowing attackers to authenticate with the identities of victim users who click on a malicious deep link. Update Gematik Authenticator to version 4.16.0 or greater to receive a patch. There are no known workarounds.

Weakness: CWE-940 (Improper Verification of Source of a Communication Channel)

## Which versions are affected by CVE-2026-33875?

It affects 1 product.


Products: Gematik Authenticator.

## How do I fix CVE-2026-33875?

No fix has been published for CVE-2026-33875 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-33875 being exploited?

There is no known exploitation of CVE-2026-33875 in the wild and no public exploit code.

## Other vulnerabilities in gematik app-Authenticator

- [CVE-2026-33874](https://insights.sbomify.com/CVE-2026-33874/): Authenticator vulnerable to Remote Code Execution (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33875 and fix it if it is affected.

What it is: CVE-2026-33875 is a critical vulnerability in gematik app-Authenticator, published on 27 Mar 2026. 
Exploitation: There is no known exploitation of CVE-2026-33875 in the wild and no public exploit code.

Affected product: gematik app-Authenticator. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33875/ (Markdown: https://insights.sbomify.com/CVE-2026-33875/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33875
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33875
- OSV: https://osv.dev/vulnerability/CVE-2026-33875

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33875/
Summaries are generated and may contain mistakes; the official description above is the record.
