# CVE-2026-33877: ApostropheCMS: User Enumeration via Timing Side Channel in Password Reset Endpoint

> Unauthenticated attackers can enumerate valid usernames and emails via timing differences in the password reset endpoint, facilitating credential stuffing and phishing.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2026
- **Updated:** 15 Apr 2026
- **Also known as:** GHSA-mj7r-x3h3-7rmr

## What is CVE-2026-33877?

CVE-2026-33877 is a low-severity vulnerability in apostrophecms apostrophe, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ApostropheCMS is an open-source Node.js content management system. Versions 4.28.0 and prior contain a timing side-channel vulnerability in the password reset endpoint (/api/v1/@apostrophecms/login/reset-request) that allows unauthenticated username and email enumeration. When a user is not found, the handler returns after a fixed 2-second artificial delay, but when a valid user is found, it performs a MongoDB update and SMTP email send with no equivalent delay normalization, producing measurably different response times. The endpoint also accepts both username and email via an $or query, and has no rate limiting as the existing checkLoginAttempts throttle only applies to the login flow. This enables automated enumeration of valid accounts for use in credential stuffing or targeted phishing. Only instances that have explicitly enabled the passwordReset option are affected, as it defaults to false. This issue has been fixed in version 4.29.0.

Weakness: CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2026-33877?

2 open source packages ship an affected version, including apostrophe. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apostrophe` | npm | All versions | 4.29.0 |
| `apostrophe` | npm | All versions | 4.29.0 |

Products: Apostrophecms Apostrophecms.

## How do I fix CVE-2026-33877?

Upgrade apostrophe to 4.29.0 or later.

## Is CVE-2026-33877 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33877 exists.

## Other vulnerabilities in apostrophecms apostrophe

- [CVE-2021-25979](https://insights.sbomify.com/CVE-2021-25979/): Apostrophe - Insufficient Session Expiration (critical 9.8)
- [CVE-2026-35569](https://insights.sbomify.com/CVE-2026-35569/): ApostropheCMS: Stored XSS in SEO Fields Leads to Authenticated API Data Exposure in ApostropheCMS (high 8.7)
- [CVE-2026-32730](https://insights.sbomify.com/CVE-2026-32730/): ApostropheCMS MFA/TOTP Bypass via Incorrect MongoDB Query in Bearer Token Middleware (high 8.1)
- [CVE-2026-40186](https://insights.sbomify.com/CVE-2026-40186/): ApostropheCMS: sanitize-html allowedTags Bypass via Entity-Decoded Text in nonTextTags Elements (medium 6.1)
- [CVE-2026-33889](https://insights.sbomify.com/CVE-2026-33889/): ApostropheCMS: Stored XSS via CSS Custom Property Injection in `@apostrophecms/color-field` Escaping Style Tag Context (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33877 and fix it if it is affected.

What it is: CVE-2026-33877 is a low-severity vulnerability in apostrophecms apostrophe, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33877 exists.

Affected packages and fixed versions:
- apostrophe (npm): affected all versions; fixed in 4.29.0
- apostrophe (npm): affected all versions; fixed in 4.29.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33877/ (Markdown: https://insights.sbomify.com/CVE-2026-33877/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33877
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33877
- OSV: https://osv.dev/vulnerability/CVE-2026-33877

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33877/
Summaries are generated and may contain mistakes; the official description above is the record.
