CVE-2026-33888 ApostropheCMS: publicApiProjection Bypass via `project` Query Builder in Piece-Type REST API

Medium 5.3 Published Updated

Unauthenticated attackers can bypass public API restrictions to read sensitive fields by manipulating query parameters in ApostropheCMS.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-33888?

CVE-2026-33888 is a medium-severity missing authorization vulnerability in apostrophecms apostrophe, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

ApostropheCMS is an open-source Node.js content management system. Versions 4.28.0 and prior contain an authorization bypass vulnerability in the getRestQuery method of the @apostrophecms/piece-type module, where the method checks whether a MongoDB projection has already been set before applying the admin-configured publicApiProjection. An unauthenticated attacker can supply a project query parameter in the REST API request, which is processed by applyBuildersSafely before the permission check, pre-populating the projection state and causing the publicApiProjection to be skipped entirely. This allows disclosure of any field on publicly queryable documents that the administrator explicitly restricted from the public API, such as internal notes, draft content, or metadata. Exploitation is trivial, requiring only appending query parameters to a public URL with no authentication. This issue has been fixed in version 4.29.0.

Weakness: CWE-863, CWE-200

Which versions are affected by CVE-2026-33888?

2 open source packages ship an affected version, including apostrophe. It affects 1 product.

PackageAffectedFixed in
apostrophe npmAll versions4.29.0
apostrophe npmAll versions4.29.0

Products include Apostrophecms Apostrophecms.

How do I fix CVE-2026-33888?

Upgrade apostrophe to 4.29.0 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-33888 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33888 exists.

Sources

Also known as GHSA-xhq9-58fw-859p.

Is CVE-2026-33888 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free