{"answers":{"affected":"2 open source packages ship an affected version, including apostrophe. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33888 exists.","fix":"Upgrade apostrophe to 4.29.0 or later.","what":"CVE-2026-33888 is a medium-severity missing authorization vulnerability in apostrophecms apostrophe, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-33888 and fix it if it is affected.\n\nWhat it is: CVE-2026-33888 is a medium-severity missing authorization vulnerability in apostrophecms apostrophe, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33888 exists.\n\nAffected packages and fixed versions:\n- apostrophe (npm): affected all versions; fixed in 4.29.0\n- apostrophe (npm): affected all versions; fixed in 4.29.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-33888/ (Markdown: https://insights.sbomify.com/CVE-2026-33888/index.md)","id":"CVE-2026-33888","markdown":"https://insights.sbomify.com/CVE-2026-33888/index.md","name":"CVE-2026-33888","record":{"aliases":["GHSA-xhq9-58fw-859p"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js CMS","requires_auth":"none","summary":"Unauthenticated attackers can bypass public API restrictions to read sensitive fields by manipulating query parameters in ApostropheCMS.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"apostrophecms","vendor":"apostrophecms"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"ApostropheCMS is an open-source Node.js content management system. Versions 4.28.0 and prior contain an authorization bypass vulnerability in the getRestQuery method of the @apostrophecms/piece-type module, where the method checks whether a MongoDB projection has already been set before applying the admin-configured publicApiProjection. An unauthenticated attacker can supply a project query parameter in the REST API request, which is processed by applyBuildersSafely before the permission check, pre-populating the projection state and causing the publicApiProjection to be skipped entirely. This allows disclosure of any field on publicly queryable documents that the administrator explicitly restricted from the public API, such as internal notes, draft content, or metadata. Exploitation is trivial, requiring only appending query parameters to a public URL with no authentication. This issue has been fixed in version 4.29.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"ApostropheCMS: publicApiProjection Bypass via `project` Query Builder in Piece-Type REST API","id":"CVE-2026-33888","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"ApostropheCMS: Stored XSS via CSS Custom Property Injection in `@apostrophecms/color-field` Escaping Style Tag Context","id":"CVE-2026-33889"},"packages":[{"ecosystem":"npm","fixed":["4.29.0"],"introduced":["0"],"last_affected":[],"package":"apostrophe","purl":null,"source":"GHSA-xhq9-58fw-859p"},{"ecosystem":"npm","fixed":["4.29.0"],"introduced":["0"],"last_affected":[],"package":"apostrophe","purl":"pkg:npm/apostrophe","source":"GHSA-xhq9-58fw-859p"}],"prev":{"headline":"Statamic allows unauthorized content access through missing authorization in its revision controllers","id":"CVE-2026-33887"},"products":["apostrophe"],"published":"2026-04-15","related":[{"cvss_score":9.8,"headline":"Apostrophe - Insufficient Session Expiration","id":"CVE-2021-25979","kev_date_added":null,"published":"2021-11-08"},{"cvss_score":8.7,"headline":"ApostropheCMS: Stored XSS in SEO Fields Leads to Authenticated API Data Exposure in ApostropheCMS","id":"CVE-2026-35569","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":8.1,"headline":"ApostropheCMS MFA/TOTP Bypass via Incorrect MongoDB Query in Bearer Token Middleware","id":"CVE-2026-32730","kev_date_added":null,"published":"2026-03-18"},{"cvss_score":6.1,"headline":"ApostropheCMS: sanitize-html allowedTags Bypass via Entity-Decoded Text in nonTextTags Elements","id":"CVE-2026-40186","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":5.4,"headline":"ApostropheCMS: Stored XSS via CSS Custom Property Injection in `@apostrophecms/color-field` Escaping Style Tag Context","id":"CVE-2026-33889","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":5.4,"headline":"Apostrophe - XSS","id":"CVE-2021-25978","kev_date_added":null,"published":"2021-11-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-15","vendors":["apostrophecms"]},"summary":"Unauthenticated attackers can bypass public API restrictions to read sensitive fields by manipulating query parameters in ApostropheCMS.","url":"https://insights.sbomify.com/CVE-2026-33888/"}