{"answers":{"affected":"2 open source packages ship an affected version, including apostrophe. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33889 exists.","fix":"Upgrade apostrophe to 4.29.0 or later.","what":"CVE-2026-33889 is a medium-severity cross-site scripting vulnerability in apostrophecms apostrophe, published on 15 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-33889 and fix it if it is affected.\n\nWhat it is: CVE-2026-33889 is a medium-severity cross-site scripting vulnerability in apostrophecms apostrophe, published on 15 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33889 exists.\n\nAffected packages and fixed versions:\n- apostrophe (npm): affected all versions; fixed in 4.29.0\n- apostrophe (npm): affected all versions; fixed in 4.29.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-33889/ (Markdown: https://insights.sbomify.com/CVE-2026-33889/index.md)","id":"CVE-2026-33889","markdown":"https://insights.sbomify.com/CVE-2026-33889/index.md","name":"CVE-2026-33889","record":{"aliases":["GHSA-97v6-998m-fp4g"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"ApostropheCMS color field","requires_auth":"low_privilege","summary":"An editor can inject JavaScript via CSS custom properties in the color field, leading to stored XSS and potential admin account takeover for all visitors.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"apostrophecms","vendor":"apostrophecms"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"ApostropheCMS is an open-source Node.js content management system. Versions 4.28.0 and prior contain a stored cross-site scripting vulnerability in the @apostrophecms/color-field module, where color values prefixed with -- bypass TinyColor validation intended for CSS custom properties, and the launder.string() call performs only type coercion without stripping HTML metacharacters. These unsanitized values are then concatenated directly into \u003cstyle\u003e tags both in per-widget style elements rendered for all visitors and in the global stylesheet rendered for editors, with the output marked as safe HTML. An editor can inject a value which closes the style tag and executes arbitrary JavaScript in the browser of every visitor to any page containing the affected widget. This enables mass session hijacking, cookie theft, and privilege escalation to administrative control if an admin views draft content. This issue has been fixed in version 4.29.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"ApostropheCMS: Stored XSS via CSS Custom Property Injection in `@apostrophecms/color-field` Escaping Style Tag Context","id":"CVE-2026-33889","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"MyTube has an Unauthenticated Admin Privilege Escalation via Passkey Registration","id":"CVE-2026-33890"},"packages":[{"ecosystem":"npm","fixed":["4.29.0"],"introduced":["0"],"last_affected":[],"package":"apostrophe","purl":null,"source":"GHSA-97v6-998m-fp4g"},{"ecosystem":"npm","fixed":["4.29.0"],"introduced":["0"],"last_affected":[],"package":"apostrophe","purl":"pkg:npm/apostrophe","source":"GHSA-97v6-998m-fp4g"}],"prev":{"headline":"ApostropheCMS: publicApiProjection Bypass via `project` Query Builder in Piece-Type REST API","id":"CVE-2026-33888"},"products":["apostrophe"],"published":"2026-04-15","related":[{"cvss_score":9.8,"headline":"Apostrophe - Insufficient Session Expiration","id":"CVE-2021-25979","kev_date_added":null,"published":"2021-11-08"},{"cvss_score":8.7,"headline":"ApostropheCMS: Stored XSS in SEO Fields Leads to Authenticated API Data Exposure in ApostropheCMS","id":"CVE-2026-35569","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":8.1,"headline":"ApostropheCMS MFA/TOTP Bypass via Incorrect MongoDB Query in Bearer Token Middleware","id":"CVE-2026-32730","kev_date_added":null,"published":"2026-03-18"},{"cvss_score":6.1,"headline":"ApostropheCMS: sanitize-html allowedTags Bypass via Entity-Decoded Text in nonTextTags Elements","id":"CVE-2026-40186","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":5.4,"headline":"Apostrophe - XSS","id":"CVE-2021-25978","kev_date_added":null,"published":"2021-11-07"},{"cvss_score":5.3,"headline":"ApostropheCMS: publicApiProjection Bypass via `project` Query Builder in Piece-Type REST API","id":"CVE-2026-33888","kev_date_added":null,"published":"2026-04-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-16","vendors":["apostrophecms"]},"summary":"An editor can inject JavaScript via CSS custom properties in the color field, leading to stored XSS and potential admin account takeover for all visitors.","url":"https://insights.sbomify.com/CVE-2026-33889/"}