# CVE-2026-33889: ApostropheCMS: Stored XSS via CSS Custom Property Injection in `@apostrophecms/color-field` Escaping Style Tag Context

> An editor can inject JavaScript via CSS custom properties in the color field, leading to stored XSS and potential admin account takeover for all visitors.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Apr 2026
- **Updated:** 16 Apr 2026
- **Also known as:** GHSA-97v6-998m-fp4g

## What is CVE-2026-33889?

CVE-2026-33889 is a medium-severity cross-site scripting vulnerability in apostrophecms apostrophe, published on 15 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

ApostropheCMS is an open-source Node.js content management system. Versions 4.28.0 and prior contain a stored cross-site scripting vulnerability in the @apostrophecms/color-field module, where color values prefixed with -- bypass TinyColor validation intended for CSS custom properties, and the launder.string() call performs only type coercion without stripping HTML metacharacters. These unsanitized values are then concatenated directly into <style> tags both in per-widget style elements rendered for all visitors and in the global stylesheet rendered for editors, with the output marked as safe HTML. An editor can inject a value which closes the style tag and executes arbitrary JavaScript in the browser of every visitor to any page containing the affected widget. This enables mass session hijacking, cookie theft, and privilege escalation to administrative control if an admin views draft content. This issue has been fixed in version 4.29.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-33889?

2 open source packages ship an affected version, including apostrophe. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apostrophe` | npm | All versions | 4.29.0 |
| `apostrophe` | npm | All versions | 4.29.0 |

Products: Apostrophecms Apostrophecms.

## How do I fix CVE-2026-33889?

Upgrade apostrophe to 4.29.0 or later.

## Is CVE-2026-33889 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33889 exists.

## Other vulnerabilities in apostrophecms apostrophe

- [CVE-2021-25979](https://insights.sbomify.com/CVE-2021-25979/): Apostrophe - Insufficient Session Expiration (critical 9.8)
- [CVE-2026-35569](https://insights.sbomify.com/CVE-2026-35569/): ApostropheCMS: Stored XSS in SEO Fields Leads to Authenticated API Data Exposure in ApostropheCMS (high 8.7)
- [CVE-2026-32730](https://insights.sbomify.com/CVE-2026-32730/): ApostropheCMS MFA/TOTP Bypass via Incorrect MongoDB Query in Bearer Token Middleware (high 8.1)
- [CVE-2026-40186](https://insights.sbomify.com/CVE-2026-40186/): ApostropheCMS: sanitize-html allowedTags Bypass via Entity-Decoded Text in nonTextTags Elements (medium 6.1)
- [CVE-2021-25978](https://insights.sbomify.com/CVE-2021-25978/): Apostrophe - XSS (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33889 and fix it if it is affected.

What it is: CVE-2026-33889 is a medium-severity cross-site scripting vulnerability in apostrophecms apostrophe, published on 15 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33889 exists.

Affected packages and fixed versions:
- apostrophe (npm): affected all versions; fixed in 4.29.0
- apostrophe (npm): affected all versions; fixed in 4.29.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33889/ (Markdown: https://insights.sbomify.com/CVE-2026-33889/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33889
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33889
- OSV: https://osv.dev/vulnerability/CVE-2026-33889

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33889/
Summaries are generated and may contain mistakes; the official description above is the record.
