# CVE-2026-33895: Forge has signature forgery in Ed25519 due to missing S > L check

> Attackers can forge Ed25519 signatures to bypass authentication or authorization checks in applications using the Forge library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Mar 2026
- **Updated:** 4 Sep 2026
- **Also known as:** CLEANSTART-2026-ER79648, CLEANSTART-2026-PF59420, CLEANSTART-2026-WM82942, GHSA-q67f-28xg-22rw, MINI-276x-g45r-j6cx, MINI-48q6-4j7p-67xc, MINI-5qw9-mph8-97pp, MINI-5v8c-8q8w-h4m3, MINI-5x65-qcc6-qmg2, MINI-9mf9-p43c-vprg, MINI-c45f-c34h-5q5w, MINI-c54q-6xrj-6cr8, MINI-fmp3-5mrq-r5q4, MINI-gr35-v96m-f4p9, MINI-h7q9-gqgj-3jxq, MINI-hfwv-q9h2-57j3, MINI-mf9r-w74h-997q, MINI-pg58-v5cc-j2qf, MINI-rhc7-f3qp-g78x, MINI-rj4p-m987-gc96, MINI-wfrx-4wjp-7f9c, MINI-wg3v-mpg3-96cq, MINI-xp24-vgpr-8wgw, ROOT-APP-NPM-CVE-2026-33895, UBUNTU-CVE-2026-33895

## What is CVE-2026-33895?

CVE-2026-33895 is a high-severity vulnerability in digitalbazaar forge, published on 27 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Forge (also called `node-forge`) is a native implementation of Transport Layer Security in JavaScript. Prior to version 1.4.0, Ed25519 signature verification accepts forged non-canonical signatures where the scalar S is not reduced modulo the group order (`S >= L`). A valid signature and its `S + L` variant both verify in forge, while Node.js `crypto.verify` (OpenSSL-backed) rejects the `S + L` variant, as defined by the specification. This class of signature malleability has been exploited in practice to bypass authentication and authorization logic (see CVE-2026-25793, CVE-2022-35961). Applications relying on signature uniqueness (i.e., dedup by signature bytes, replay tracking, signed-object canonicalization checks) may be bypassed. Version 1.4.0 patches the issue.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2026-33895?

2 open source packages ship an affected version, including node-forge. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node-forge` | npm | All versions | 1.4.0 |
| `node-forge` | npm | All versions | 1.4.0 |

Products: Digitalbazaar Forge.

## How do I fix CVE-2026-33895?

Upgrade node-forge to 1.4.0 or later.

## Is CVE-2026-33895 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33895 exists.

## Other vulnerabilities in digitalbazaar forge

- [CVE-2020-7720](https://insights.sbomify.com/CVE-2020-7720/): Prototype Pollution (critical 9.8)
- [CVE-2025-66031](https://insights.sbomify.com/CVE-2025-66031/): node-forge ASN.1 Unbounded Recursion (high 8.7)
- [CVE-2025-12816](https://insights.sbomify.com/CVE-2025-12816/): CVE-2025-12816 (high 8.6)
- [CVE-2026-33891](https://insights.sbomify.com/CVE-2026-33891/): Forge has Denial of Service via Infinite Loop in BigInteger.modInverse() with Zero Input (high 7.5)
- [CVE-2026-33894](https://insights.sbomify.com/CVE-2026-33894/): Forge has signature forgery in RSA-PKCS due to ASN.1 extra field (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33895 and fix it if it is affected.

What it is: CVE-2026-33895 is a high-severity vulnerability in digitalbazaar forge, published on 27 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33895 exists.

Affected packages and fixed versions:
- node-forge (npm): affected all versions; fixed in 1.4.0
- node-forge (npm): affected all versions; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33895/ (Markdown: https://insights.sbomify.com/CVE-2026-33895/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33895
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33895
- OSV: https://osv.dev/vulnerability/CVE-2026-33895

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33895/
Summaries are generated and may contain mistakes; the official description above is the record.
