# CVE-2026-33897: Incus vulnerable to arbitrary file read and write through pongo templates

> Attackers can exploit pongo2 templates to bypass chroot isolation, enabling arbitrary file read and write as root on the host system.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Mar 2026
- **Updated:** 27 Mar 2026
- **Also known as:** DEBIAN-CVE-2026-33897, GHSA-83xr-5xxr-mh92, GO-2026-4881, UBUNTU-CVE-2026-33897

## What is CVE-2026-33897?

CVE-2026-33897 is a critical path traversal vulnerability in lxc incus, published on 26 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incus is a system container and virtual machine manager. Prior to version 6.23.0, instance template files can be used to cause arbitrary read or writes as root on the host server. Incus allows for pongo2 templates within instances which can be used at various times in the instance lifecycle to template files inside of the instance. This particular implementation of pongo2 within Incus allowed for file read/write but with the expectation that the pongo2 chroot feature would isolate all such access to the instance's filesystem. This was allowed such that a template could theoretically read a file and then generate a new version of said file. Unfortunately the chroot isolation mechanism is entirely skipped by pongo2 leading to easy access to the entire system's filesystem with root privileges. Version 6.23.0 patches the issue.

Weakness: CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-33897?

6 open source packages ship an affected version, including github.com/lxc/incus and github.com/lxc/incus/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lxc/incus` | Go | All versions | None |
| `github.com/lxc/incus` | Go | All versions to 0.7.0 | None |
| `github.com/lxc/incus` | Go | All versions to 0.7.0 | None |
| `github.com/lxc/incus/v6` | Go | All versions | 6.23.0 |
| `github.com/lxc/incus/v6` | Go | All versions | 6.23.0 |
| `github.com/lxc/incus/v6` | Go | All versions | 6.23.0 |

Products: Linuxcontainers Incus.

## How do I fix CVE-2026-33897?

Upgrade to a fixed version.

## Is CVE-2026-33897 being exploited?

There is no known exploitation of CVE-2026-33897 in the wild and no public exploit code.

## Other vulnerabilities in lxc incus

- [CVE-2026-33945](https://insights.sbomify.com/CVE-2026-33945/): Abitrary file write through systemd-creds option (critical 10.0)
- [CVE-2026-33898](https://insights.sbomify.com/CVE-2026-33898/): Local Incus UI web server vulnerable to nuthentication bypass (high 8.8)
- [CVE-2026-23953](https://insights.sbomify.com/CVE-2026-23953/): Incus container environment configuration newline injection (high 8.7)
- [CVE-2026-23954](https://insights.sbomify.com/CVE-2026-23954/): Incus container image templating arbitrary host file read and write (high 8.7)
- [CVE-2025-64507](https://insights.sbomify.com/CVE-2025-64507/): Incus vulnerable to local privilege escalation through custom storage volumes (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33897 and fix it if it is affected.

What it is: CVE-2026-33897 is a critical path traversal vulnerability in lxc incus, published on 26 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33897 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/lxc/incus (Go): affected all versions; no fix listed
- github.com/lxc/incus (Go): affected all versions up to 0.7.0; no fix listed
- github.com/lxc/incus (Go): affected all versions up to 0.7.0; no fix listed
- github.com/lxc/incus/v6 (Go): affected all versions; fixed in 6.23.0
- github.com/lxc/incus/v6 (Go): affected all versions; fixed in 6.23.0
- github.com/lxc/incus/v6 (Go): affected all versions; fixed in 6.23.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33897/ (Markdown: https://insights.sbomify.com/CVE-2026-33897/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33897
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33897
- OSV: https://osv.dev/vulnerability/CVE-2026-33897

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33897/
Summaries are generated and may contain mistakes; the official description above is the record.
