# CVE-2026-33898: Local Incus UI web server vulnerable to nuthentication bypass

> Attackers can bypass authentication in the local Incus UI web server to access user instances and escalate privileges.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Mar 2026
- **Updated:** 30 Mar 2026
- **Also known as:** DEBIAN-CVE-2026-33898, GHSA-453r-g2pg-cxxq, GO-2026-4879, UBUNTU-CVE-2026-33898

## What is CVE-2026-33898?

CVE-2026-33898 is a high-severity authentication bypass vulnerability in lxc incus, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Incus is a system container and virtual machine manager. Prior to version 6.23.0, the web server spawned by `incus webui` incorrectly validates the authentication token such that an invalid value will be accepted. `incus webui` runs a local web server on a random localhost port. For authentication, it provides the user with a URL containing an authentication token. When accessed with that token, Incus creates a cookie persisting that token without needing to include it in subsequent HTTP requests. While the Incus client correctly validates the value of the cookie, it does not correctly validate the token when passed int the URL.
This allows for an attacker able to locate and talk to the temporary web server on localhost to have as much access to Incus as the user who ran `incus webui`. This can lead to privilege escalation by another local user or an access to the user's Incus instances and possibly system resources by a remote attack able to trick the local user into interacting with the Incus UI web server. Version 6.23.0 patches the issue.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-33898?

4 open source packages ship an affected version, including github.com/lxc/incus/v6/cmd/incus, github.com/lxc/incus and github.com/lxc/incus/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lxc/incus/v6/cmd/incus` | Go | All versions | 6.23.0 |
| `github.com/lxc/incus/v6/cmd/incus` | Go | All versions | 6.23.0 |
| `github.com/lxc/incus` | Go | All versions | None |
| `github.com/lxc/incus/v6` | Go | All versions | 6.23.0 |

Products: Linuxcontainers Incus.

## How do I fix CVE-2026-33898?

Upgrade github.com/lxc/incus/v6/cmd/incus to 6.23.0 or later.

## Is CVE-2026-33898 being exploited?

There is no known exploitation of CVE-2026-33898 in the wild and no public exploit code.

## Other vulnerabilities in lxc incus

- [CVE-2026-33897](https://insights.sbomify.com/CVE-2026-33897/): Incus vulnerable to arbitrary file read and write through pongo templates (critical 10.0)
- [CVE-2026-33945](https://insights.sbomify.com/CVE-2026-33945/): Abitrary file write through systemd-creds option (critical 10.0)
- [CVE-2026-23953](https://insights.sbomify.com/CVE-2026-23953/): Incus container environment configuration newline injection (high 8.7)
- [CVE-2026-23954](https://insights.sbomify.com/CVE-2026-23954/): Incus container image templating arbitrary host file read and write (high 8.7)
- [CVE-2025-64507](https://insights.sbomify.com/CVE-2025-64507/): Incus vulnerable to local privilege escalation through custom storage volumes (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33898 and fix it if it is affected.

What it is: CVE-2026-33898 is a high-severity authentication bypass vulnerability in lxc incus, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-33898 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/lxc/incus/v6/cmd/incus (Go): affected all versions; fixed in 6.23.0
- github.com/lxc/incus/v6/cmd/incus (Go): affected all versions; fixed in 6.23.0
- github.com/lxc/incus (Go): affected all versions; no fix listed
- github.com/lxc/incus/v6 (Go): affected all versions; fixed in 6.23.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33898/ (Markdown: https://insights.sbomify.com/CVE-2026-33898/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33898
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33898
- OSV: https://osv.dev/vulnerability/CVE-2026-33898

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33898/
Summaries are generated and may contain mistakes; the official description above is the record.
