# CVE-2026-33936: python-ecdsa: Denial of Service via improper DER length validation in crafted private keys

> Attackers can cause denial of service in applications parsing untrusted DER private keys by triggering unhandled exceptions in the python-ecdsa library.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Mar 2026
- **Updated:** 1 Apr 2026
- **Also known as:** AZL-80975, CLEANSTART-2026-OH68688, DEBIAN-CVE-2026-33936, ECHO-dc11-daa6-fc93, GHSA-9f5j-8jwj-x28g, MINI-qcwf-3r36-gh33, OESA-2026-1828, OESA-2026-1829, OESA-2026-1836, OESA-2026-1837, OESA-2026-1838, OESA-2026-1839, PYSEC-2026-2467, ROOT-APP-PYPI-CVE-2026-33936, SUSE-SU-2026:1436-1, SUSE-SU-2026:1608-1, SUSE-SU-2026:22158-1, UBUNTU-CVE-2026-33936, openSUSE-SU-2026:10468-1, openSUSE-SU-2026:21078-1

## What is CVE-2026-33936?

CVE-2026-33936 is a medium-severity denial of service vulnerability in tlsfuzzer python-ecdsa, published on 27 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The `ecdsa` PyPI package is a pure Python implementation of ECC (Elliptic Curve Cryptography) with support for ECDSA (Elliptic Curve Digital Signature Algorithm), EdDSA (Edwards-curve Digital Signature Algorithm) and ECDH (Elliptic Curve Diffie-Hellman). Prior to version 0.19.2, an issue in the low-level DER parsing functions can cause unexpected exceptions to be raised from the public API functions. `ecdsa.der.remove_octet_string()` accepts truncated DER where the encoded length exceeds the available buffer. For example, an OCTET STRING that declares a length of 4096 bytes but provides only 3 bytes is parsed successfully instead of being rejected. Because of that, a crafted DER input can cause `SigningKey.from_der()` to raise an internal exception (`IndexError: index out of bounds on dimension 1`) rather than cleanly rejecting malformed DER (e.g., raising `UnexpectedDER` or `ValueError`). Applications that parse untrusted DER private keys may crash if they do not handle unexpected exceptions, resulting in a denial of service. Version 0.19.2 patches the issue.

Weakness: CWE-20 (Improper Input Validation), CWE-130 (Improper Handling of Length Parameter Inconsistency)

## Which versions are affected by CVE-2026-33936?

3 open source packages ship an affected version, including ecdsa. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ecdsa` | PyPI | All versions | 0.19.2 |
| `ecdsa` | PyPI | All versions | 0.19.2 |
| `ecdsa` | PyPI | All versions | 0.19.2 |
| `python-ecdsa` | SUSE:Linux Enterprise Module for Basesystem 15 SP7 | All versions | 0.13.3-150000.3.10.1 |
| `python-ecdsa` | SUSE:Linux Enterprise Module for Python 3 15 SP7 | All versions | 0.18.0-150400.12.6.1 |
| `python-ecdsa` | SUSE:Linux Enterprise Server 16.0 | All versions | 0.19.1-160000.4.1 |
| `python-ecdsa` | SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 0.19.1-160000.4.1 |
| `python-ecdsa` | openSUSE:Leap 15.6 | All versions | 0.18.0-150400.12.6.1 |
| `python-ecdsa` | openSUSE:Leap 16.0 | All versions | 0.19.1-160000.4.1 |
| `python-ecdsa` | openSUSE:Tumbleweed | All versions | 0.19.2-1.1 |

Products: Tlsfuzzer Ecdsa.

## How do I fix CVE-2026-33936?

Upgrade ecdsa to 0.19.2 or later.

## Is CVE-2026-33936 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33936 exists.

Public exploit code:

- Denial of Service vulnerability in ecdsa (PyPI) (github_poc): https://github.com/0xmrma/CVE-2026-33936

## Other vulnerabilities in tlsfuzzer python-ecdsa

- [CVE-2024-23342](https://insights.sbomify.com/CVE-2024-23342/): python-ecdsa vulnerable to Minerva attack on P-256 (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33936 and fix it if it is affected.

What it is: CVE-2026-33936 is a medium-severity denial of service vulnerability in tlsfuzzer python-ecdsa, published on 27 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33936 exists.

Affected packages and fixed versions:
- ecdsa (PyPI): affected all versions; fixed in 0.19.2
- ecdsa (PyPI): affected all versions; fixed in 0.19.2
- ecdsa (PyPI): affected all versions; fixed in 0.19.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33936/ (Markdown: https://insights.sbomify.com/CVE-2026-33936/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33936
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33936
- OSV: https://osv.dev/vulnerability/CVE-2026-33936

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33936/
Summaries are generated and may contain mistakes; the official description above is the record.
