# CVE-2026-33938: Handlebars.js has JavaScript Injection via AST Type Confusion by tampering @partial-block

> Attackers can execute arbitrary JavaScript on the server by tampering with the @partial-block variable in Handlebars.js templates.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Mar 2026
- **Updated:** 4 Sep 2026
- **Also known as:** CLEANSTART-2026-HJ03986, CLEANSTART-2026-SJ54112, DEBIAN-CVE-2026-33938, GHSA-3mfm-83xf-c92r, MINI-36gh-g93m-h9c9, MINI-46j2-m5vq-x4cv, MINI-5c82-vrmm-5j54, MINI-7p4m-49jx-x754, MINI-g9cm-48c2-9hrq, MINI-j277-qqc6-585c, MINI-jj6q-8fv9-24vw, MINI-jpr3-87gp-7g8f, MINI-jv5m-fjc2-8m2g, MINI-mm73-crch-3984, MINI-pj32-4q84-vp9r, MINI-qcv5-6x94-f54j, MINI-r64x-mhjm-p9w3, MINI-rjq9-878c-gj9r, ROOT-APP-NPM-CVE-2026-33938, UBUNTU-CVE-2026-33938

## What is CVE-2026-33938?

CVE-2026-33938 is a high-severity code injection vulnerability in handlebars-lang handlebars.js, published on 27 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Handlebars provides the power necessary to let users build semantic templates. In versions 4.0.0 through 4.7.8, the `@partial-block` special variable is stored in the template data context and is reachable and mutable from within a template via helpers that accept arbitrary objects. When a helper overwrites `@partial-block` with a crafted Handlebars AST, a subsequent invocation of `{{> @partial-block}}` compiles and executes that AST, enabling arbitrary JavaScript execution on the server. Version 4.7.9 fixes the issue. Some workarounds are available. First, use the runtime-only build (`require('handlebars/runtime')`). The `compile()` method is  absent, eliminating the vulnerable fallback path. Second, audit registered helpers for any that write arbitrary values to context objects. Helpers  should treat context data as read-only. Third, avoid registering helpers from third-party packages (such as `handlebars-helpers`) in  contexts where templates or context data can be influenced by untrusted input.

Weakness: CWE-917 (Improper Neutralization of Special Elements used in an Expression Language Statement), CWE-94 (Improper Control of Generation of Code), CWE-843 (Access of Resource Using Incompatible Type)

## Which versions are affected by CVE-2026-33938?

2 open source packages ship an affected version, including handlebars. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `handlebars` | npm | From 4.0.0 | 4.7.9 |
| `handlebars` | npm | From 4.0.0 | 4.7.9 |

Products: Handlebarsjs Handlebars.

## How do I fix CVE-2026-33938?

Upgrade handlebars to 4.7.9 or later.

## Is CVE-2026-33938 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33938 exists.

## Other vulnerabilities in handlebars-lang handlebars.js

- [CVE-2026-33937](https://insights.sbomify.com/CVE-2026-33937/): Handlebars.js has JavaScript Injection via AST Type Confusion (critical 9.8)
- [CVE-2026-33941](https://insights.sbomify.com/CVE-2026-33941/): Handlebars.js has JavaScript Injection in CLI Precompiler via Unescaped Names and Options (high 8.3)
- [CVE-2026-33940](https://insights.sbomify.com/CVE-2026-33940/): Handlebars.js has JavaScript Injection via AST Type Confusion when passing an object as dynamic partial (high 8.1)
- [CVE-2019-20920](https://insights.sbomify.com/CVE-2019-20920/): Arbitrary Code Execution in Handlebars (high 8.1)
- [CVE-2026-33939](https://insights.sbomify.com/CVE-2026-33939/): Handlebars.js has Denial of Service via Malformed Decorator Syntax in Template Compilation (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33938 and fix it if it is affected.

What it is: CVE-2026-33938 is a high-severity code injection vulnerability in handlebars-lang handlebars.js, published on 27 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33938 exists.

Affected packages and fixed versions:
- handlebars (npm): affected from 4.0.0; fixed in 4.7.9
- handlebars (npm): affected from 4.0.0; fixed in 4.7.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33938/ (Markdown: https://insights.sbomify.com/CVE-2026-33938/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33938
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33938
- OSV: https://osv.dev/vulnerability/CVE-2026-33938

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33938/
Summaries are generated and may contain mistakes; the official description above is the record.
