# CVE-2026-33940: Handlebars.js has JavaScript Injection via AST Type Confusion when passing an object as dynamic partial

> Attackers can execute arbitrary code on the server by injecting a crafted object into the template context during dynamic partial resolution.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Mar 2026
- **Updated:** 4 Sep 2026
- **Also known as:** CLEANSTART-2026-OR11868, CLEANSTART-2026-XH19639, DEBIAN-CVE-2026-33940, GHSA-xhpv-hc6g-r9c6, MINI-26q8-5v4j-3gj6, MINI-2p9g-24rf-j696, MINI-58hc-4247-53c5, MINI-5gpq-xpgp-mm4c, MINI-5wcq-3q7g-m2fc, MINI-6h2g-jmp7-3x55, MINI-c657-76x8-f7pf, MINI-cgf6-3j6c-qr24, MINI-mh7m-p55j-jgr3, MINI-pw6h-ffx8-89hv, MINI-qh6m-w8r3-682q, MINI-rgvp-vwxx-52xp, MINI-rhfp-w69c-f6fr, MINI-x63g-3gf8-wh3g, ROOT-APP-NPM-CVE-2026-33940, UBUNTU-CVE-2026-33940

## What is CVE-2026-33940?

CVE-2026-33940 is a high-severity code injection vulnerability in handlebars-lang handlebars.js, published on 27 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Handlebars provides the power necessary to let users build semantic templates. In versions 4.0.0 through 4.7.8, a crafted object placed in the template context can bypass all conditional guards in `resolvePartial()` and cause `invokePartial()` to return `undefined`. The Handlebars runtime then treats the unresolved partial as a source that needs to be compiled, passing the crafted object to `env.compile()`. Because the object is a valid Handlebars AST containing injected code, the generated JavaScript executes arbitrary commands on the server. The attack requires the adversary to control a value that can be returned by a dynamic partial lookup. Version 4.7.9 fixes the issue. Some workarounds are available. First, use the runtime-only build (`require('handlebars/runtime')`). Without `compile()`,  the fallback compilation path in `invokePartial` is unreachable. Second, sanitize context data before rendering: Ensure no value in the context is a non-primitive  object that could be passed to a dynamic partial. Third, avoid dynamic partial lookups (`{{> (lookup ...)}}`) when context data is user-controlled.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-843 (Access of Resource Using Incompatible Type)

## Which versions are affected by CVE-2026-33940?

2 open source packages ship an affected version, including handlebars. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `handlebars` | npm | From 4.0.0 | 4.7.9 |
| `handlebars` | npm | From 4.0.0 | 4.7.9 |

Products: Handlebarsjs Handlebars.

## How do I fix CVE-2026-33940?

Upgrade handlebars to 4.7.9 or later.

## Is CVE-2026-33940 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33940 exists.

## Other vulnerabilities in handlebars-lang handlebars.js

- [CVE-2026-33937](https://insights.sbomify.com/CVE-2026-33937/): Handlebars.js has JavaScript Injection via AST Type Confusion (critical 9.8)
- [CVE-2026-33941](https://insights.sbomify.com/CVE-2026-33941/): Handlebars.js has JavaScript Injection in CLI Precompiler via Unescaped Names and Options (high 8.3)
- [CVE-2026-33938](https://insights.sbomify.com/CVE-2026-33938/): Handlebars.js has JavaScript Injection via AST Type Confusion by tampering @partial-block (high 8.1)
- [CVE-2019-20920](https://insights.sbomify.com/CVE-2019-20920/): Arbitrary Code Execution in Handlebars (high 8.1)
- [CVE-2026-33939](https://insights.sbomify.com/CVE-2026-33939/): Handlebars.js has Denial of Service via Malformed Decorator Syntax in Template Compilation (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33940 and fix it if it is affected.

What it is: CVE-2026-33940 is a high-severity code injection vulnerability in handlebars-lang handlebars.js, published on 27 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33940 exists.

Affected packages and fixed versions:
- handlebars (npm): affected from 4.0.0; fixed in 4.7.9
- handlebars (npm): affected from 4.0.0; fixed in 4.7.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33940/ (Markdown: https://insights.sbomify.com/CVE-2026-33940/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33940
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33940
- OSV: https://osv.dev/vulnerability/CVE-2026-33940

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33940/
Summaries are generated and may contain mistakes; the official description above is the record.
