# CVE-2026-33945: Abitrary file write through systemd-creds option

> Attackers can write arbitrary files as root via path traversal in systemd credential configuration, leading to privilege escalation or denial of service.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Mar 2026
- **Updated:** 27 Mar 2026
- **Also known as:** DEBIAN-CVE-2026-33945, GHSA-q4q8-7f2j-9h9f, GO-2026-4884, UBUNTU-CVE-2026-33945

## What is CVE-2026-33945?

CVE-2026-33945 is a critical path traversal vulnerability in lxc incus, published on 26 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incus is a system container and virtual machine manager. Incus instances have an option to provide credentials to systemd in the guest. For containers, this is handled through a shared directory. Prior to version 6.23.0, an attacker can set a configuration key named something like `systemd.credential.../../../../../../root/.bashrc` to cause Incus to write outside of the `credentials` directory associated with the container. This makes use of the fact that the Incus syntax for such credentials is `systemd.credential.XYZ` where `XYZ` can itself contain more periods. While it's not possible to read any data this way, it's possible to write to arbitrary files as root, enabling both privilege escalation and denial of service attacks. Version 6.23.0 fixes the issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-33945?

4 open source packages ship an affected version, including github.com/lxc/incus/v6 and github.com/lxc/incus. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lxc/incus/v6` | Go | All versions | 6.23.0 |
| `github.com/lxc/incus/v6` | Go | All versions | 6.23.0 |
| `github.com/lxc/incus/v6` | Go | All versions | 6.23.0 |
| `github.com/lxc/incus` | Go | All versions | None |

Products: Linuxcontainers Incus.

## How do I fix CVE-2026-33945?

Upgrade github.com/lxc/incus/v6 to 6.23.0 or later.

## Is CVE-2026-33945 being exploited?

There is no known exploitation of CVE-2026-33945 in the wild and no public exploit code.

## Other vulnerabilities in lxc incus

- [CVE-2026-33897](https://insights.sbomify.com/CVE-2026-33897/): Incus vulnerable to arbitrary file read and write through pongo templates (critical 10.0)
- [CVE-2026-33898](https://insights.sbomify.com/CVE-2026-33898/): Local Incus UI web server vulnerable to nuthentication bypass (high 8.8)
- [CVE-2026-23953](https://insights.sbomify.com/CVE-2026-23953/): Incus container environment configuration newline injection (high 8.7)
- [CVE-2026-23954](https://insights.sbomify.com/CVE-2026-23954/): Incus container image templating arbitrary host file read and write (high 8.7)
- [CVE-2025-64507](https://insights.sbomify.com/CVE-2025-64507/): Incus vulnerable to local privilege escalation through custom storage volumes (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33945 and fix it if it is affected.

What it is: CVE-2026-33945 is a critical path traversal vulnerability in lxc incus, published on 26 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33945 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/lxc/incus/v6 (Go): affected all versions; fixed in 6.23.0
- github.com/lxc/incus/v6 (Go): affected all versions; fixed in 6.23.0
- github.com/lxc/incus/v6 (Go): affected all versions; fixed in 6.23.0
- github.com/lxc/incus (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33945/ (Markdown: https://insights.sbomify.com/CVE-2026-33945/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33945
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33945
- OSV: https://osv.dev/vulnerability/CVE-2026-33945

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33945/
Summaries are generated and may contain mistakes; the official description above is the record.
