{"answers":{"affected":"2 open source packages ship an affected version, including express-xss-sanitizer. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33979 exists.","fix":"Upgrade express-xss-sanitizer to 2.0.2 or later.","what":"CVE-2026-33979 is a high-severity cross-site scripting vulnerability in AhmedAdelFahim express-xss-sanitizer, published on 27 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-33979 and fix it if it is affected.\n\nWhat it is: CVE-2026-33979 is a high-severity cross-site scripting vulnerability in AhmedAdelFahim express-xss-sanitizer, published on 27 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33979 exists.\n\nAffected packages and fixed versions:\n- express-xss-sanitizer (npm): affected all versions; fixed in 2.0.2\n- express-xss-sanitizer (npm): affected all versions; fixed in 2.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-33979/ (Markdown: https://insights.sbomify.com/CVE-2026-33979/index.md)","id":"CVE-2026-33979","markdown":"https://insights.sbomify.com/CVE-2026-33979/index.md","name":"CVE-2026-33979","record":{"aliases":["GHSA-3843-rr4g-m8jq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Express XSS sanitizer","requires_auth":"none","summary":"Attackers can bypass XSS sanitization in Express applications by exploiting ignored restrictive configurations, potentially executing malicious scripts.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"express_xss_sanitizer","vendor":"express_xss_sanitizer_project"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-183","name":"Permissive List of Allowed Inputs"}],"description":"Express XSS Sanitizer is Express 4.x and 5.x middleware which sanitizes user input data (in req.body, req.query, req.headers and req.params) to prevent Cross Site Scripting (XSS) attack. A vulnerability has been identified in versions prior to 2.0.2 where restrictive sanitization configurations are silently ignored. In version 2.0.2, the validation logic has been updated to respect explicitly provided empty configurations. Now, if allowedTags or allowedAttributes are provided (even if empty), they are passed directly to sanitize-html without being overridden.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Express XSS Sanitizer: allowedTags/allowedAttributes bypass leads to permissive sanitization (XSS risk)","id":"CVE-2026-33979","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Azure Data Explorer MCP Server: KQL Injection in multiple tools allows MCP client to execute arbitrary Kusto queries","id":"CVE-2026-33980"},"packages":[{"ecosystem":"npm","fixed":["2.0.2"],"introduced":["0"],"last_affected":[],"package":"express-xss-sanitizer","purl":null,"source":"GHSA-3843-rr4g-m8jq"},{"ecosystem":"npm","fixed":["2.0.2"],"introduced":["0"],"last_affected":[],"package":"express-xss-sanitizer","purl":"pkg:npm/express-xss-sanitizer","source":"GHSA-3843-rr4g-m8jq"}],"prev":{"headline":"Notesnook: Stored XSS in mobile share editor via unescaped web clip title metadata","id":"CVE-2026-33978"},"products":["express-xss-sanitizer"],"published":"2026-03-27","related":[{"cvss_score":7.3,"headline":"Prototype Pollution","id":"CVE-2022-21169","kev_date_added":null,"published":"2022-09-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-31","vendors":["AhmedAdelFahim"]},"summary":"Attackers can bypass XSS sanitization in Express applications by exploiting ignored restrictive configurations, potentially executing malicious scripts.","url":"https://insights.sbomify.com/CVE-2026-33979/"}