CVE-2026-34020 Apache OpenMeetings: Login Credentials Passed via GET Query Parameters

High 7.5 Published Updated

Attackers can intercept credentials because the login endpoint transmits them via GET query parameters.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-34020?

CVE-2026-34020 is a high-severity vulnerability in Apache OpenMeetings, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Use of GET Request Method With Sensitive Query Strings vulnerability in Apache OpenMeetings.

The REST login endpoint uses HTTP GET method with username and password passed as query parameters. Please check references regarding possible impact

This issue affects Apache OpenMeetings: from 3.1.3 before 9.0.0.

Users are recommended to upgrade to version 9.0.0, which fixes the issue.

Weakness: CWE-598

Which versions are affected by CVE-2026-34020?

2 open source packages ship an affected version, including org.apache.openmeetings:openmeetings-parent. It affects 1 product.

PackageAffectedFixed in
org.apache.openmeetings:openmeetings-parent MavenFrom 3.1.39.0.0
org.apache.openmeetings:openmeetings-parent MavenFrom 3.1.39.0.0

Products include Apache Openmeetings.

How do I fix CVE-2026-34020?

Upgrade org.apache.openmeetings:openmeetings-parent to 9.0.0 or later.

Is CVE-2026-34020 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34020 exists.

Sources

Also known as GHSA-gcvm-c75m-h4p4.

Is CVE-2026-34020 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free