{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.openmeetings:openmeetings-parent. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34020 exists.","fix":"Upgrade org.apache.openmeetings:openmeetings-parent to 9.0.0 or later.","what":"CVE-2026-34020 is a high-severity vulnerability in Apache OpenMeetings, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-34020 and fix it if it is affected.\n\nWhat it is: CVE-2026-34020 is a high-severity vulnerability in Apache OpenMeetings, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34020 exists.\n\nAffected packages and fixed versions:\n- org.apache.openmeetings:openmeetings-parent (Maven): affected from 3.1.3; fixed in 9.0.0\n- org.apache.openmeetings:openmeetings-parent (Maven): affected from 3.1.3; fixed in 9.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-34020/ (Markdown: https://insights.sbomify.com/CVE-2026-34020/index.md)","id":"CVE-2026-34020","markdown":"https://insights.sbomify.com/CVE-2026-34020/index.md","name":"CVE-2026-34020","record":{"aliases":["GHSA-gcvm-c75m-h4p4"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache OpenMeetings","requires_auth":"none","summary":"Attackers can intercept credentials because the login endpoint transmits them via GET query parameters.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"openmeetings","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-598","name":"Use of HTTP Request With Sensitive Query String"}],"description":"Use of GET Request Method With Sensitive Query Strings vulnerability in Apache OpenMeetings.\n\nThe REST login endpoint uses HTTP GET method with username and password passed as query parameters. Please check references regarding possible impact\n\nThis issue affects Apache OpenMeetings: from 3.1.3 before 9.0.0.\n\nUsers are recommended to upgrade to version 9.0.0, which fixes the issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Apache OpenMeetings: Login Credentials Passed via GET Query Parameters","id":"CVE-2026-34020","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Lack of cryptographic protection in Wertheim SafeController 5400 enables RS-485 message sniffing and replay","id":"CVE-2026-34021"},"packages":[{"ecosystem":"Maven","fixed":["9.0.0"],"introduced":["3.1.3"],"last_affected":[],"package":"org.apache.openmeetings:openmeetings-parent","purl":null,"source":"GHSA-gcvm-c75m-h4p4"},{"ecosystem":"Maven","fixed":["9.0.0"],"introduced":["3.1.3"],"last_affected":[],"package":"org.apache.openmeetings:openmeetings-parent","purl":"pkg:maven/org.apache.openmeetings/openmeetings-parent","source":"GHSA-gcvm-c75m-h4p4"}],"prev":{"headline":"BIG-IP BFD vulnerability","id":"CVE-2026-34019"},"products":["Apache OpenMeetings"],"published":"2026-04-09","related":[{"cvss_score":10,"headline":"Apache OpenMeetings does not correctly validate uploaded XML documents","id":"CVE-2017-7664","kev_date_added":null,"published":"2017-07-14"},{"cvss_score":9.8,"headline":"Apache OpenMeetings: Deserialisation of untrusted data in cluster mode","id":"CVE-2024-54676","kev_date_added":null,"published":"2025-01-08"},{"cvss_score":9.8,"headline":"Apache OpenMeetings: allows user impersonation","id":"CVE-2023-28326","kev_date_added":null,"published":"2023-03-28"},{"cvss_score":9.8,"headline":"Apache OpenMeetings RCE","id":"CVE-2016-8736","kev_date_added":null,"published":"2017-10-12"},{"cvss_score":9.8,"headline":"Apache OpenMeetings has Inadequate Encryption Strength","id":"CVE-2017-7673","kev_date_added":null,"published":"2017-07-14"},{"cvss_score":8.8,"headline":"Apache OpenMeetings vulnerable to Cross-Site Request Forgery","id":"CVE-2017-7666","kev_date_added":null,"published":"2017-07-14"},{"cvss_score":8.8,"headline":"Apache OpenMeetings vulnerable to SQL injection","id":"CVE-2017-7681","kev_date_added":null,"published":"2017-07-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-10","vendors":["Apache Software Foundation"]},"summary":"Attackers can intercept credentials because the login endpoint transmits them via GET query parameters.","url":"https://insights.sbomify.com/CVE-2026-34020/"}