# CVE-2026-34020: Apache OpenMeetings: Login Credentials Passed via GET Query Parameters

> Attackers can intercept credentials because the login endpoint transmits them via GET query parameters.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2026
- **Updated:** 10 Apr 2026
- **Also known as:** GHSA-gcvm-c75m-h4p4

## What is CVE-2026-34020?

CVE-2026-34020 is a high-severity vulnerability in Apache OpenMeetings, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Use of GET Request Method With Sensitive Query Strings vulnerability in Apache OpenMeetings.

The REST login endpoint uses HTTP GET method with username and password passed as query parameters. Please check references regarding possible impact

This issue affects Apache OpenMeetings: from 3.1.3 before 9.0.0.

Users are recommended to upgrade to version 9.0.0, which fixes the issue.

Weakness: CWE-598 (Use of HTTP Request With Sensitive Query String)

## Which versions are affected by CVE-2026-34020?

2 open source packages ship an affected version, including org.apache.openmeetings:openmeetings-parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.openmeetings:openmeetings-parent` | Maven | From 3.1.3 | 9.0.0 |
| `org.apache.openmeetings:openmeetings-parent` | Maven | From 3.1.3 | 9.0.0 |

Products: Apache Openmeetings.

## How do I fix CVE-2026-34020?

Upgrade org.apache.openmeetings:openmeetings-parent to 9.0.0 or later.

## Is CVE-2026-34020 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34020 exists.

## Other vulnerabilities in Apache OpenMeetings

- [CVE-2017-7664](https://insights.sbomify.com/CVE-2017-7664/): Apache OpenMeetings does not correctly validate uploaded XML documents (critical 10.0)
- [CVE-2024-54676](https://insights.sbomify.com/CVE-2024-54676/): Apache OpenMeetings: Deserialisation of untrusted data in cluster mode (critical 9.8)
- [CVE-2023-28326](https://insights.sbomify.com/CVE-2023-28326/): Apache OpenMeetings: allows user impersonation (critical 9.8)
- [CVE-2016-8736](https://insights.sbomify.com/CVE-2016-8736/): Apache OpenMeetings RCE (critical 9.8)
- [CVE-2017-7673](https://insights.sbomify.com/CVE-2017-7673/): Apache OpenMeetings has Inadequate Encryption Strength (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34020 and fix it if it is affected.

What it is: CVE-2026-34020 is a high-severity vulnerability in Apache OpenMeetings, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34020 exists.

Affected packages and fixed versions:
- org.apache.openmeetings:openmeetings-parent (Maven): affected from 3.1.3; fixed in 9.0.0
- org.apache.openmeetings:openmeetings-parent (Maven): affected from 3.1.3; fixed in 9.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34020/ (Markdown: https://insights.sbomify.com/CVE-2026-34020/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34020
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34020
- OSV: https://osv.dev/vulnerability/CVE-2026-34020

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34020/
Summaries are generated and may contain mistakes; the official description above is the record.
