CVE-2026-34032 Apache HTTP Server: mod_proxy_ajp: Heap Buffer Over-Read Due to Missing Null-Termination Check (ajp_msg_get_string)

Medium 5.3 Published Updated

An attacker can trigger a heap buffer over-read in Apache HTTP Server's mod_proxy_ajp module, potentially leading to information disclosure or service disruption.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-34032?

CVE-2026-34032 is a medium-severity memory corruption vulnerability in Apache Http Server, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper Null Termination, Out-of-bounds Read vulnerability in Apache HTTP Server.

This issue affects Apache HTTP Server: through 2.4.66.

Users are recommended to upgrade to version 2.4.67, which fixes the issue.

Weakness: CWE-170, CWE-125

Which versions are affected by CVE-2026-34032?

1 open source package ship an affected version, including apache. It affects 1 product.

PackageAffectedFixed in
apache BitnamiAll versions2.4.67

Products include Apache Http Server.

How do I fix CVE-2026-34032?

Upgrade apache to 2.4.67 or later.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-34032 being exploited?

There is no known exploitation of CVE-2026-34032 in the wild and no public exploit code.

All Apache Http Server vulnerabilities

Sources

Also known as ALPINE-CVE-2026-34032, AZL-86010, BELL-CVE-2026-34032, BIT-apache-2026-34032, DEBIAN-CVE-2026-34032, GHSA-9r79-gvhp-cr42 and 3 more.

Is CVE-2026-34032 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free