# CVE-2026-34033: Apache Answer: HTML Content Injection in Email

> Authenticated users can inject arbitrary HTML into notification emails sent to other users, potentially leading to script execution.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Jun 2026
- **Updated:** 9 Jun 2026
- **Also known as:** GHSA-6qwm-5fm9-cvjx, GO-2026-6151

## What is CVE-2026-34033?

CVE-2026-34033 is a medium-severity cross-site scripting vulnerability in Apache Answer, published on 9 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache Answer.

This issue affects Apache Answer: through 2.0.0.

User-supplied content was included in notification emails without proper escaping, allowing authenticated users to inject arbitrary HTML into emails sent to other users.
Users are recommended to upgrade to version 2.0.1, which fixes the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2026-34033?

3 open source packages ship an affected version, including github.com/apache/incubator-answer and github.com/apache/answer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/apache/incubator-answer` | Go | All versions | 1.7.2-0.20260509080709-d1a4092c61cc |
| `github.com/apache/incubator-answer` | Go | All versions | 1.7.2-0.20260509080709-d1a4092c61cc |
| `github.com/apache/answer` | Go | All versions | 1.7.2-0.20260509080709-d1a4092c61cc |

Products: Apache Answer.

## How do I fix CVE-2026-34033?

Upgrade github.com/apache/incubator-answer to 1.7.2-0.20260509080709-d1a4092c61cc or later.

## Is CVE-2026-34033 being exploited?

There is no known exploitation of CVE-2026-34033 in the wild and no public exploit code.

## Other vulnerabilities in Apache Answer

- [CVE-2026-60053](https://insights.sbomify.com/CVE-2026-60053/): Apache Answer: Residual Administrative API Key Access After Role or Account Revocation (critical 9.1)
- [CVE-2024-22393](https://insights.sbomify.com/CVE-2024-22393/): Apache Answer: Pixel Flood Attack by uploading the large pixel file (critical 9.1)
- [CVE-2026-48834](https://insights.sbomify.com/CVE-2026-48834/): Apache Answer: Denial of service via crafted Accept-Language header parsing (high 7.5)
- [CVE-2026-48911](https://insights.sbomify.com/CVE-2026-48911/): Apache Answer: Unauthenticated OAuth Email-Binding Account Takeover via Existing User Confirmation Flow (high 7.5)
- [CVE-2026-60023](https://insights.sbomify.com/CVE-2026-60023/): Apache Answer: Unauthorized disclosure of deleted or pending answer content (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34033 and fix it if it is affected.

What it is: CVE-2026-34033 is a medium-severity cross-site scripting vulnerability in Apache Answer, published on 9 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-34033 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/apache/incubator-answer (Go): affected all versions; fixed in 1.7.2-0.20260509080709-d1a4092c61cc
- github.com/apache/incubator-answer (Go): affected all versions; fixed in 1.7.2-0.20260509080709-d1a4092c61cc
- github.com/apache/answer (Go): affected all versions; fixed in 1.7.2-0.20260509080709-d1a4092c61cc

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34033/ (Markdown: https://insights.sbomify.com/CVE-2026-34033/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34033
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34033
- OSV: https://osv.dev/vulnerability/CVE-2026-34033

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34033/
Summaries are generated and may contain mistakes; the official description above is the record.
