# CVE-2026-34036: Dolibarr Core Discloses Sensitive Data via Authenticated Local File Inclusion in selectobject.php

> Authenticated users can read arbitrary non-PHP files on the server via a Local File Inclusion vulnerability in Dolibarr's selectobject.php endpoint.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2026
- **Updated:** 31 Mar 2026
- **Also known as:** GHSA-2mfj-r695-5h9r, UBUNTU-CVE-2026-34036

## What is CVE-2026-34036?

CVE-2026-34036 is a medium-severity path traversal vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 31 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Dolibarr is an enterprise resource planning (ERP) and customer relationship management (CRM) software package. In versions 22.0.4 and prior, there is a Local File Inclusion (LFI) vulnerability in the core AJAX endpoint /core/ajax/selectobject.php. By manipulating the objectdesc parameter and exploiting a fail-open logic flaw in the core access control function restrictedArea(), an authenticated user with no specific privileges can read the contents of arbitrary non-PHP files on the server (such as .env, .htaccess, configuration backups, or logs…). At time of publication, there are no publicly available patches.

Weakness: CWE-98 (Improper Control of Filename for Include/Require Statement in PHP Program)

## Which versions are affected by CVE-2026-34036?

2 open source packages ship an affected version, including dolibarr/dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | All versions | 23.0.0 |
| `dolibarr/dolibarr` | Packagist | All versions | 23.0.0 |

Products: Dolibarr Dolibarr Erp\/Crm.

## How do I fix CVE-2026-34036?

Upgrade dolibarr/dolibarr to 23.0.0 or later.

## Is CVE-2026-34036 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34036 exists.

Public exploit code:

- PoC Script for CVE-2026-34036. For educational purposes only. (github_poc): https://github.com/cnf409/CVE-2026-34036
- Dolibarr <=22.0.4 - Local File Inclusion (nuclei): http/cves/2026/CVE-2026-34036.yaml

## Other vulnerabilities in Dolibarr Dolibarr Erp\/Crm

- [CVE-2022-43138](https://insights.sbomify.com/CVE-2022-43138/): Dolibarr vulnerable to privilege escalation (critical 9.8)
- [CVE-2022-40871](https://insights.sbomify.com/CVE-2022-40871/): Dolibarr vulnerable to Eval Injection (critical 9.8)
- [CVE-2021-33816](https://insights.sbomify.com/CVE-2021-33816/): Dolibarr remote PHP code execution (critical 9.8)
- [CVE-2020-7995](https://insights.sbomify.com/CVE-2020-7995/): Dolibarr Improper Restriction of Excessive Authentication Attempts (critical 9.8)
- [CVE-2013-2091](https://insights.sbomify.com/CVE-2013-2091/): SQL injection in dolibarr (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34036 and fix it if it is affected.

What it is: CVE-2026-34036 is a medium-severity path traversal vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 31 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34036 exists.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 23.0.0
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 23.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34036/ (Markdown: https://insights.sbomify.com/CVE-2026-34036/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34036
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34036
- OSV: https://osv.dev/vulnerability/CVE-2026-34036

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34036/
Summaries are generated and may contain mistakes; the official description above is the record.
