# CVE-2026-34046: Langflow: Authenticated Users Can Read, Modify, and Delete Any Flow via Missing Ownership Check

> Authenticated users can read, modify, or delete other users' AI workflows and exposed API keys due to missing ownership checks.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Mar 2026
- **Updated:** 1 Apr 2026
- **Also known as:** GHSA-8c4j-f57c-35cf, PYSEC-2026-2567, PYSEC-2026-2570

## What is CVE-2026-34046?

CVE-2026-34046 is a high-severity missing authorization vulnerability in Langflow Langflow, published on 27 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Langflow is a tool for building and deploying AI-powered agents and workflows. Prior to version 1.5.1, the `_read_flow` helper in `src/backend/base/langflow/api/v1/flows.py` branched on the `AUTO_LOGIN` setting to decide whether to filter by `user_id`. When `AUTO_LOGIN` was `False` (i.e., authentication was enabled), neither branch enforced an ownership check — the query returned any flow matching the given UUID regardless of who owned it. This allowed any authenticated user to read any other user's flow, including embedded plaintext API keys; modify the logic of another user's AI agents, and/or delete flows belonging to other users. The vulnerability was introduced by the conditional logic that was meant to accommodate public/example flows (those with `user_id = NULL`) under auto-login mode, but inadvertently left the authenticated path without an ownership filter. The fix in version 1.5.1 removes the `AUTO_LOGIN` conditional entirely and unconditionally scopes the query to the requesting user.

Weakness: CWE-862 (Missing Authorization), CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-34046?

6 open source packages ship an affected version, including langflow and langflow-base. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langflow` | PyPI | All versions | 1.5.1 |
| `langflow` | PyPI | All versions | 1.5.1 |
| `langflow` | PyPI | All versions | 1.5.1 |
| `langflow-base` | PyPI | All versions | 0.5.1 |
| `langflow-base` | PyPI | All versions | 0.5.1 |
| `langflow-base` | PyPI | All versions | 0.5.1 |

Products: Langflow Langflow, Langflow Langflow-Base.

## How do I fix CVE-2026-34046?

Upgrade langflow to 1.5.1 or later.

## Is CVE-2026-34046 being exploited?

There is no known exploitation of CVE-2026-34046 in the wild and no public exploit code.

## Other vulnerabilities in Langflow Langflow

- [CVE-2026-9198](https://insights.sbomify.com/CVE-2026-9198/): IBM Langflow Code Injection (critical 9.8, exploited in the wild)
- [CVE-2026-0770](https://insights.sbomify.com/CVE-2026-0770/): Langflow Inclusion of Functionality from Untrusted Control Sphere (critical 9.8, exploited in the wild)
- [CVE-2025-3248](https://insights.sbomify.com/CVE-2025-3248/): Langflow Missing Authentication (critical 9.8, exploited in the wild)
- [CVE-2025-34291](https://insights.sbomify.com/CVE-2025-34291/): Langflow Origin Validation Error (critical 9.4, exploited in the wild)
- [CVE-2026-33017](https://insights.sbomify.com/CVE-2026-33017/): Langflow Code Injection (critical 9.3, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34046 and fix it if it is affected.

What it is: CVE-2026-34046 is a high-severity missing authorization vulnerability in Langflow Langflow, published on 27 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34046 in the wild and no public exploit code.

Affected packages and fixed versions:
- langflow (PyPI): affected all versions; fixed in 1.5.1
- langflow (PyPI): affected all versions; fixed in 1.5.1
- langflow (PyPI): affected all versions; fixed in 1.5.1
- langflow-base (PyPI): affected all versions; fixed in 0.5.1
- langflow-base (PyPI): affected all versions; fixed in 0.5.1
- langflow-base (PyPI): affected all versions; fixed in 0.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34046/ (Markdown: https://insights.sbomify.com/CVE-2026-34046/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34046
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34046
- OSV: https://osv.dev/vulnerability/CVE-2026-34046

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34046/
Summaries are generated and may contain mistakes; the official description above is the record.
