CVE-2026-34059 Apache HTTP Server: mod_proxy_ajp: Heap Over-Read and memory disclosure in ajp_parse_data()

High 7.5 Published Updated

An attacker can trigger a heap over-read in mod_proxy_ajp to disclose sensitive memory contents from the Apache HTTP Server.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-34059?

CVE-2026-34059 is a high-severity vulnerability in Apache Http Server, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Buffer Over-read vulnerability in Apache HTTP Server.

This issue affects Apache HTTP Server: through 2.4.66.

Users are recommended to upgrade to version 2.4.67, which fixes the issue.

Weakness: CWE-126

Which versions are affected by CVE-2026-34059?

1 open source package ship an affected version, including apache. It affects 1 product.

PackageAffectedFixed in
apache BitnamiAll versions2.4.67

Products include Apache Http Server.

How do I fix CVE-2026-34059?

Upgrade apache to 2.4.67 or later.

Is CVE-2026-34059 being exploited?

There is no known exploitation of CVE-2026-34059 in the wild and no public exploit code.

All Apache Http Server vulnerabilities

Sources

Also known as ALPINE-CVE-2026-34059, AZL-86001, BELL-CVE-2026-34059, BIT-apache-2026-34059, DEBIAN-CVE-2026-34059, GHSA-m35f-pf48-r38q and 3 more.

Is CVE-2026-34059 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free