CVE-2026-34060 Ruby LSP has arbitrary code execution through branch setting

High 7.1 Published Updated

Attackers can execute arbitrary Ruby code by crafting a malicious workspace setting in a project opened with Ruby LSP.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-34060?

CVE-2026-34060 is a high-severity code injection vulnerability in Shopify.ruby-lsp, published on 31 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

Ruby LSP is an implementation of the language server protocol for Ruby. Prior to Shopify.ruby-lsp version 0.10.2 and ruby-lsp version 0.26.9, the rubyLsp.branch VS Code workspace setting was interpolated without sanitization into a generated Gemfile, allowing arbitrary Ruby code execution when a user opens a project containing a malicious .vscode/settings.json. This issue has been patched in Shopify.ruby-lsp version 0.10.2 and ruby-lsp version 0.26.9.

Weakness: CWE-94

Which versions are affected by CVE-2026-34060?

2 open source packages ship an affected version, including ruby-lsp. It affects 1 product.

PackageAffectedFixed in
ruby-lsp RubyGemsAll versions0.26.9
ruby-lsp RubyGemsAll versions0.26.9

Products include Shopify Ruby Lsp.

How do I fix CVE-2026-34060?

Upgrade ruby-lsp to 0.26.9 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-34060 being exploited?

There is no known exploitation of CVE-2026-34060 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-34060, GHSA-c4r5-fxqw-vh93.

Is CVE-2026-34060 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free