{"answers":{"affected":"2 open source packages ship an affected version, including ruby-lsp. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-34060 in the wild and no public exploit code.","fix":"Upgrade ruby-lsp to 0.26.9 or later.","what":"CVE-2026-34060 is a high-severity code injection vulnerability in Shopify.ruby-lsp, published on 31 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-34060 and fix it if it is affected.\n\nWhat it is: CVE-2026-34060 is a high-severity code injection vulnerability in Shopify.ruby-lsp, published on 31 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-34060 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ruby-lsp (RubyGems): affected all versions; fixed in 0.26.9\n- ruby-lsp (RubyGems): affected all versions; fixed in 0.26.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-34060/ (Markdown: https://insights.sbomify.com/CVE-2026-34060/index.md)","id":"CVE-2026-34060","markdown":"https://insights.sbomify.com/CVE-2026-34060/index.md","name":"CVE-2026-34060","record":{"aliases":["DEBIAN-CVE-2026-34060","GHSA-c4r5-fxqw-vh93"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ruby language server","requires_auth":"none","summary":"Attackers can execute arbitrary Ruby code by crafting a malicious workspace setting in a project opened with Ruby LSP.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ruby_lsp","vendor":"shopify"}],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Ruby LSP is an implementation of the language server protocol for Ruby. Prior to Shopify.ruby-lsp version 0.10.2 and ruby-lsp version 0.26.9, the rubyLsp.branch VS Code workspace setting was interpolated without sanitization into a generated Gemfile, allowing arbitrary Ruby code execution when a user opens a project containing a malicious .vscode/settings.json. This issue has been patched in Shopify.ruby-lsp version 0.10.2 and ruby-lsp version 0.26.9.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ruby LSP has arbitrary code execution through branch setting","id":"CVE-2026-34060","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"nimiq/core-rs-albatross: Macro block proposal interlink bug","id":"CVE-2026-34061"},"packages":[{"ecosystem":"RubyGems","fixed":["0.26.9"],"introduced":["0"],"last_affected":[],"package":"ruby-lsp","purl":null,"source":"GHSA-c4r5-fxqw-vh93"},{"ecosystem":"RubyGems","fixed":["0.26.9"],"introduced":["0"],"last_affected":[],"package":"ruby-lsp","purl":"pkg:gem/ruby-lsp","source":"GHSA-c4r5-fxqw-vh93"}],"prev":{"headline":"Apache HTTP Server: mod_proxy_ajp: Heap Over-Read and memory disclosure in ajp_parse_data()","id":"CVE-2026-34059"},"products":["Shopify.ruby-lsp","ruby-lsp"],"published":"2026-03-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-02","vendors":["Shopify"]},"summary":"Attackers can execute arbitrary Ruby code by crafting a malicious workspace setting in a project opened with Ruby LSP.","url":"https://insights.sbomify.com/CVE-2026-34060/"}