# CVE-2026-34060: Ruby LSP has arbitrary code execution through branch setting

> Attackers can execute arbitrary Ruby code by crafting a malicious workspace setting in a project opened with Ruby LSP.

- **Severity:** High 7.1 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Mar 2026
- **Updated:** 2 Apr 2026
- **Also known as:** DEBIAN-CVE-2026-34060, GHSA-c4r5-fxqw-vh93

## What is CVE-2026-34060?

CVE-2026-34060 is a high-severity code injection vulnerability in Shopify.ruby-lsp, published on 31 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Ruby LSP is an implementation of the language server protocol for Ruby. Prior to Shopify.ruby-lsp version 0.10.2 and ruby-lsp version 0.26.9, the rubyLsp.branch VS Code workspace setting was interpolated without sanitization into a generated Gemfile, allowing arbitrary Ruby code execution when a user opens a project containing a malicious .vscode/settings.json. This issue has been patched in Shopify.ruby-lsp version 0.10.2 and ruby-lsp version 0.26.9.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-34060?

2 open source packages ship an affected version, including ruby-lsp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ruby-lsp` | RubyGems | All versions | 0.26.9 |
| `ruby-lsp` | RubyGems | All versions | 0.26.9 |

Products: Shopify Ruby Lsp.

## How do I fix CVE-2026-34060?

Upgrade ruby-lsp to 0.26.9 or later.

## Is CVE-2026-34060 being exploited?

There is no known exploitation of CVE-2026-34060 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34060 and fix it if it is affected.

What it is: CVE-2026-34060 is a high-severity code injection vulnerability in Shopify.ruby-lsp, published on 31 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-34060 in the wild and no public exploit code.

Affected packages and fixed versions:
- ruby-lsp (RubyGems): affected all versions; fixed in 0.26.9
- ruby-lsp (RubyGems): affected all versions; fixed in 0.26.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34060/ (Markdown: https://insights.sbomify.com/CVE-2026-34060/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34060
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34060
- OSV: https://osv.dev/vulnerability/CVE-2026-34060

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34060/
Summaries are generated and may contain mistakes; the official description above is the record.
