# CVE-2026-34073: cryptography has incomplete DNS name constraint enforcement on peer names

> Attackers can bypass DNS name constraints in the Python cryptography library, allowing unauthorized peer validation against restricted domains.

- **Severity:** Low 1.7 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2026
- **Updated:** 14 Oct 2026
- **Also known as:** ALPINE-CVE-2026-34073, BELL-CVE-2026-34073, CLEANSTART-2026-JG72912, CLEANSTART-2026-VN38539, CLSA-2026-1784164006, DEBIAN-CVE-2026-34073, ECHO-4b9f-fbf8-c429, GHSA-m959-cc7f-wv43, MINI-3252-7c8v-mw55, MINI-442x-wv88-rx39, MINI-5cvx-2hcc-4r4q, MINI-5jj6-fg2h-86cx, MINI-69gm-w5w2-28gr, MINI-72g2-2cv7-x842, MINI-7m2g-53hh-4m8r, MINI-9v9j-q6mf-gg23, MINI-g87j-wv9v-jcrw, MINI-p8cp-rjq4-jh9c, MINI-q9jf-xqh9-68p2, MINI-qg8c-6w7p-wch3, MINI-qggj-gj5h-c77j, MINI-r6fj-f96m-h989, MINI-xhc4-mx2p-r2jh, MINI-xr23-8g2v-mjww, MINI-xvjq-92v2-qw2q, PYSEC-2026-35, ROOT-APP-PYPI-CVE-2026-34073, SUSE-SU-2026:21116-1, SUSE-SU-2026:21126-1, openSUSE-SU-2026:10454-1

## What is CVE-2026-34073?

CVE-2026-34073 is a low-severity vulnerability in pyca cryptography, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. Prior to version 46.0.6, DNS name constraints were only validated against SANs within child certificates, and not the "peer name" presented during each validation. Consequently, cryptography would allow a peer named bar.example.com to validate against a wildcard leaf certificate for *.example.com, even if the leaf's parent certificate (or upwards) contained an excluded subtree constraint for bar.example.com. This issue has been patched in version 46.0.6.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-34073?

3 open source packages ship an affected version, including cryptography. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cryptography` | PyPI | All versions | 46.0.6 |
| `cryptography` | PyPI | All versions | 46.0.6 |
| `cryptography` | PyPI | All versions | 46.0.6 |
| `python-cryptography` | SUSE:Linux Micro 6.0 | All versions | 42.0.4-4.1 |
| `python-cryptography` | SUSE:Linux Micro 6.1 | All versions | 42.0.4-slfo.1.1_4.1 |
| `python-cryptography` | openSUSE:Tumbleweed | All versions | 46.0.6-1.1 |

Products: Cryptography.io Cryptography.

## How do I fix CVE-2026-34073?

Upgrade cryptography to 46.0.6 or later.

## Is CVE-2026-34073 being exploited?

There is no known exploitation of CVE-2026-34073 in the wild and no public exploit code.

## Other vulnerabilities in pyca cryptography

- [CVE-2020-36242](https://insights.sbomify.com/CVE-2020-36242/): PyCA Cryptography symmetrically encrypting large values can lead to integer overflow (critical 9.1)
- [CVE-2026-26007](https://insights.sbomify.com/CVE-2026-26007/): cryptography Subgroup Attack Due to Missing Subgroup Validation for SECT Curves (high 8.2)
- [CVE-2024-26130](https://insights.sbomify.com/CVE-2024-26130/): cryptography NULL pointer dereference with pkcs12.serialize_key_and_certificates when called with a non-matching certificate and private key and an hmac_hash override (high 7.5)
- [CVE-2023-38325](https://insights.sbomify.com/CVE-2023-38325/): cryptography mishandles SSH certificates (high 7.5)
- [CVE-2026-39892](https://insights.sbomify.com/CVE-2026-39892/): cryptography has a buffer overflow if non-contiguous buffers were passed to APIs (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34073 and fix it if it is affected.

What it is: CVE-2026-34073 is a low-severity vulnerability in pyca cryptography, published on 31 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34073 in the wild and no public exploit code.

Affected packages and fixed versions:
- cryptography (PyPI): affected all versions; fixed in 46.0.6
- cryptography (PyPI): affected all versions; fixed in 46.0.6
- cryptography (PyPI): affected all versions; fixed in 46.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34073/ (Markdown: https://insights.sbomify.com/CVE-2026-34073/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34073
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34073
- OSV: https://osv.dev/vulnerability/CVE-2026-34073

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34073/
Summaries are generated and may contain mistakes; the official description above is the record.
