# CVE-2026-34076: Clerk JavaScript: SSRF in the opt-in clerkFrontendApiProxy feature may leak secret keys to unintended host

> An unauthenticated attacker can exploit an SSRF vulnerability in the opt-in proxy feature to leak secret keys to an external server.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2026
- **Updated:** 1 Apr 2026
- **Also known as:** GHSA-gjxx-92w9-8v8f

## What is CVE-2026-34076?

CVE-2026-34076 is a high-severity server-side request forgery vulnerability in clerk javascript, published on 1 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Clerk JavaScript is the official JavaScript repository for Clerk authentication. In @clerk/hono from versions 0.1.0 to before 0.1.5, @clerk/express from versions 2.0.0 to before 2.0.7, @clerk/backend from versions 3.0.0 to before 3.2.3, and @clerk/fastify from versions 3.1.0 to before 3.1.5, the clerkFrontendApiProxy function in @clerk/backend is vulnerable to Server-Side Request Forgery (SSRF). An unauthenticated attacker can craft a request path that causes the proxy to send the application's Clerk-Secret-Key to an attacker-controlled server. This issue has been patched in @clerk/hono version 0.1.5, @clerk/express version 2.0.7, @clerk/backend version 3.2.3, and @clerk/fastify version 3.1.5.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-34076?

8 open source packages ship an affected version, including @clerk/backend, @clerk/express and @clerk/fastify.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@clerk/backend` | npm | From 3.0.0 | 3.2.3 |
| `@clerk/backend` | npm | From 3.0.0 | 3.2.3 |
| `@clerk/express` | npm | From 2.0.0 | 2.0.7 |
| `@clerk/express` | npm | From 2.0.0 | 2.0.7 |
| `@clerk/fastify` | npm | From 3.1.0 | 3.1.5 |
| `@clerk/fastify` | npm | From 3.1.0 | 3.1.5 |
| `@clerk/hono` | npm | From 0.1.0 | 0.1.5 |
| `@clerk/hono` | npm | From 0.1.0 | 0.1.5 |

## How do I fix CVE-2026-34076?

Upgrade @clerk/backend to 3.2.3 or later.

## Is CVE-2026-34076 being exploited?

There is no known exploitation of CVE-2026-34076 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34076 and fix it if it is affected.

What it is: CVE-2026-34076 is a high-severity server-side request forgery vulnerability in clerk javascript, published on 1 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34076 in the wild and no public exploit code.

Affected packages and fixed versions:
- @clerk/backend (npm): affected from 3.0.0; fixed in 3.2.3
- @clerk/backend (npm): affected from 3.0.0; fixed in 3.2.3
- @clerk/express (npm): affected from 2.0.0; fixed in 2.0.7
- @clerk/express (npm): affected from 2.0.0; fixed in 2.0.7
- @clerk/fastify (npm): affected from 3.1.0; fixed in 3.1.5
- @clerk/fastify (npm): affected from 3.1.0; fixed in 3.1.5
- @clerk/hono (npm): affected from 0.1.0; fixed in 0.1.5
- @clerk/hono (npm): affected from 0.1.0; fixed in 0.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34076/ (Markdown: https://insights.sbomify.com/CVE-2026-34076/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34076
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34076
- OSV: https://osv.dev/vulnerability/CVE-2026-34076

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34076/
Summaries are generated and may contain mistakes; the official description above is the record.
