# CVE-2026-34077: React Router vulnerable to Denial of Service via reflected user input in single-fetch

> Attackers can execute arbitrary scripts in user browsers via reflected XSS in React Router's unstable RSC redirect handling.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2026
- **Updated:** 3 Jun 2026
- **Also known as:** GHSA-rxv8-25v2-qmq8, MINI-p58x-2x3w-m3gp, ROOT-APP-NPM-CVE-2026-34077, openSUSE-SU-2026:11128-1

## What is CVE-2026-34077?

CVE-2026-34077 is a high-severity cross-site scripting vulnerability in remix-run react-router, published on 2 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

React Router is a router for React. In versions 7.7.0 through 7.13.1, when using React Router's unstable React Server Components (RSC) APIs, there is a potential client-side Cross-Site Scripting (XSS) vulnerability in the RSC redirect handling if redirects come from untrusted sources. This does not impact applications that are not using the unstable RSC APIs in React Router. This is patched in version 7.13.2.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-34077?

4 open source packages ship an affected version, including react-router and turbo-stream. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `react-router` | npm | From 7.0.0 | 7.14.0 |
| `react-router` | npm | From 7.0.0 | 7.14.0 |
| `turbo-stream` | npm | All versions | 3.0.0 |
| `turbo-stream` | npm | All versions | 3.0.0 |
| `agama-web-ui` | openSUSE:Tumbleweed | All versions | 22+143.ee15dea20-46.1 |

Products: Shopify React-Router, Turbo-Stream Turbo Stream.

## How do I fix CVE-2026-34077?

Upgrade react-router to 7.14.0 or later.

## Is CVE-2026-34077 being exploited?

There is no known exploitation of CVE-2026-34077 in the wild and no public exploit code.

## Other vulnerabilities in remix-run react-router

- [CVE-2026-55685](https://insights.sbomify.com/CVE-2026-55685/): React Router: Unauthenticated Denial of Service via Inefficient Route Matching (high 8.7)
- [CVE-2026-21884](https://insights.sbomify.com/CVE-2026-21884/): React Router SSR XSS in ScrollRestoration (high 8.2)
- [CVE-2026-42211](https://insights.sbomify.com/CVE-2026-42211/): React Router's vendored turbo-stream v2 allows arbitrary constructor invocation via TYPE_ERROR deserialization leading to Unauth RCE (high 8.1)
- [CVE-2026-33245](https://insights.sbomify.com/CVE-2026-33245/): React Router vulnerable to XSS in unstable RSC redirect handling via javascript: redirect targets (high 8.0)
- [CVE-2026-22029](https://insights.sbomify.com/CVE-2026-22029/): React Router vulnerable to XSS via Open Redirects (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34077 and fix it if it is affected.

What it is: CVE-2026-34077 is a high-severity cross-site scripting vulnerability in remix-run react-router, published on 2 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34077 in the wild and no public exploit code.

Affected packages and fixed versions:
- react-router (npm): affected from 7.0.0; fixed in 7.14.0
- react-router (npm): affected from 7.0.0; fixed in 7.14.0
- turbo-stream (npm): affected all versions; fixed in 3.0.0
- turbo-stream (npm): affected all versions; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34077/ (Markdown: https://insights.sbomify.com/CVE-2026-34077/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34077
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34077
- OSV: https://osv.dev/vulnerability/CVE-2026-34077

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34077/
Summaries are generated and may contain mistakes; the official description above is the record.
