# CVE-2026-34084: PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load

> Attackers can trigger SSRF or remote code execution via PHP stream wrappers when user-controlled filenames are passed to IOFactory::load.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2026
- **Updated:** 5 May 2026
- **Also known as:** GHSA-q4q6-r8wh-5cgh

## What is CVE-2026-34084?

CVE-2026-34084 is a critical server-side request forgery vulnerability in PHPOffice PhpSpreadsheet, published on 5 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PhpSpreadsheet is a library for reading and writing spreadsheet files. In versions 1.30.2 and earlier, 2.0.0 through 2.1.14, 2.2.0 through 2.4.3, 3.3.0 through 3.10.3, and 4.0.0 through 5.5.0, when the filename argument to IOFactory::load() is user-controlled, an attacker can supply a PHP stream wrapper path (such as phar://, ftp://, or ssh2.sftp://) that passes the is_file() check in File::assertFile(). The phar:// wrapper triggers deserialization of the PHAR metadata, which can lead to remote code execution if a suitable gadget chain is available in the application. The ftp:// and ssh2.sftp:// wrappers can be used for server-side request forgery. This issue has been fixed in versions 1.30.3, 2.1.15, 2.4.4, 3.10.4, and 5.6.0.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-34084?

10 open source packages ship an affected version, including phpoffice/phpspreadsheet. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.30.3 |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.30.3 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.0.0 | 2.1.15 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.0.0 | 2.1.15 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.2.0 | 2.4.4 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.2.0 | 2.4.4 |
| `phpoffice/phpspreadsheet` | Packagist | From 3.3.0 | 3.10.4 |
| `phpoffice/phpspreadsheet` | Packagist | From 3.3.0 | 3.10.4 |
| `phpoffice/phpspreadsheet` | Packagist | From 4.0.0 | 5.6.0 |
| `phpoffice/phpspreadsheet` | Packagist | From 4.0.0 | 5.6.0 |

Products: Phpoffice Phpspreadsheet.

## How do I fix CVE-2026-34084?

Upgrade phpoffice/phpspreadsheet to a fixed version for your release line: 1.30.3, 2.1.15, 2.4.4 or 3.10.4.

## Is CVE-2026-34084 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34084 exists.

## Other vulnerabilities in PHPOffice PhpSpreadsheet

- [CVE-2024-45048](https://insights.sbomify.com/CVE-2024-45048/): XML External Entity Reference (XXE) in PHPSpreadsheet (high 8.8)
- [CVE-2019-12331](https://insights.sbomify.com/CVE-2019-12331/): XXE in PHPSpreadsheet due to incomplete fix for previous encoding issue (high 8.8)
- [CVE-2018-19277](https://insights.sbomify.com/CVE-2018-19277/): XXE in PHPSpreadsheet due to encoding issue (high 8.8)
- [CVE-2024-56365](https://insights.sbomify.com/CVE-2024-56365/): PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class (high 8.3)
- [CVE-2024-56366](https://insights.sbomify.com/CVE-2024-56366/): PhpSpreadsheet vulnerable to unauthorized reflected XSS in the Accounting.php file (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34084 and fix it if it is affected.

What it is: CVE-2026-34084 is a critical server-side request forgery vulnerability in PHPOffice PhpSpreadsheet, published on 5 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34084 exists.

Affected packages and fixed versions:
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.30.3
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.30.3
- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.15
- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.15
- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.4.4
- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.4.4
- phpoffice/phpspreadsheet (Packagist): affected from 3.3.0; fixed in 3.10.4
- phpoffice/phpspreadsheet (Packagist): affected from 3.3.0; fixed in 3.10.4
- phpoffice/phpspreadsheet (Packagist): affected from 4.0.0; fixed in 5.6.0
- phpoffice/phpspreadsheet (Packagist): affected from 4.0.0; fixed in 5.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34084/ (Markdown: https://insights.sbomify.com/CVE-2026-34084/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34084
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34084
- OSV: https://osv.dev/vulnerability/CVE-2026-34084

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34084/
Summaries are generated and may contain mistakes; the official description above is the record.
