CVE-2026-34148 Fedify affected by resource exhaustion caused by unbounded redirect following during remote key/document resolution
An attacker can cause denial of service in Fedify-based servers by triggering unbounded HTTP redirect loops during remote document resolution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-34148?
CVE-2026-34148 is a high-severity denial of service vulnerability in @fedify fedify, published on 6 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Fedify is a TypeScript library for building federated server apps powered by ActivityPub. Prior to 1.9.6, 1.10.5, 2.0.8, and 2.1.1, @fedify/fedify follows HTTP redirects recursively in its remote document loader and authenticated document loader without enforcing a maximum redirect count or visited-URL loop detection. An attacker who controls a remote ActivityPub key or actor URL can force a server using Fedify to make repeated outbound requests from a single inbound request, leading to resource consumption and denial of service. This vulnerability is fixed in 1.9.6, 1.10.5, 2.0.8, and 2.1.1.
Which versions are affected by CVE-2026-34148?
12 open source packages ship an affected version, including @fedify/fedify and @fedify/vocab-runtime. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
@fedify/fedify npm | All versions | 1.9.6 |
@fedify/fedify npm | All versions | 1.9.6 |
@fedify/fedify npm | From 1.10.0 | 1.10.5 |
@fedify/fedify npm | From 1.10.0 | 1.10.5 |
@fedify/fedify npm | From 2.0.0 | 2.0.8 |
@fedify/fedify npm | From 2.0.0 | 2.0.8 |
6 more packages
@fedify/fedify npm | From 2.1.0 | 2.1.1 |
@fedify/fedify npm | From 2.1.0 | 2.1.1 |
@fedify/vocab-runtime npm | All versions | 2.0.8 |
@fedify/vocab-runtime npm | All versions | 2.0.8 |
@fedify/vocab-runtime npm | From 2.1.0 | 2.1.1 |
@fedify/vocab-runtime npm | From 2.1.0 | 2.1.1 |
Products include Fedify Fedify\/Fedify, Fedify Fedify\/Vocab-Runtime.
How do I fix CVE-2026-34148?
Upgrade @fedify/fedify to a fixed version for your release line: 1.9.6, 1.10.5, 2.0.8 or 2.1.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-34148 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34148 exists.
Sources
Also known as GHSA-gm9m-gwc4-hwgp.