{"answers":{"affected":"12 open source packages ship an affected version, including @fedify/fedify and @fedify/vocab-runtime. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34148 exists.","fix":"Upgrade @fedify/fedify to a fixed version for your release line: 1.9.6, 1.10.5, 2.0.8 or 2.1.1.","what":"CVE-2026-34148 is a high-severity denial of service vulnerability in @fedify fedify, published on 6 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-34148 and fix it if it is affected.\n\nWhat it is: CVE-2026-34148 is a high-severity denial of service vulnerability in @fedify fedify, published on 6 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34148 exists.\n\nAffected packages and fixed versions:\n- @fedify/fedify (npm): affected all versions; fixed in 1.9.6\n- @fedify/fedify (npm): affected all versions; fixed in 1.9.6\n- @fedify/fedify (npm): affected from 1.10.0; fixed in 1.10.5\n- @fedify/fedify (npm): affected from 1.10.0; fixed in 1.10.5\n- @fedify/fedify (npm): affected from 2.0.0; fixed in 2.0.8\n- @fedify/fedify (npm): affected from 2.0.0; fixed in 2.0.8\n- @fedify/fedify (npm): affected from 2.1.0; fixed in 2.1.1\n- @fedify/fedify (npm): affected from 2.1.0; fixed in 2.1.1\n- @fedify/vocab-runtime (npm): affected all versions; fixed in 2.0.8\n- @fedify/vocab-runtime (npm): affected all versions; fixed in 2.0.8\n- @fedify/vocab-runtime (npm): affected from 2.1.0; fixed in 2.1.1\n- @fedify/vocab-runtime (npm): affected from 2.1.0; fixed in 2.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-34148/ (Markdown: https://insights.sbomify.com/CVE-2026-34148/index.md)","id":"CVE-2026-34148","markdown":"https://insights.sbomify.com/CVE-2026-34148/index.md","name":"CVE-2026-34148","record":{"aliases":["GHSA-gm9m-gwc4-hwgp"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Fedify ActivityPub library","requires_auth":"none","summary":"An attacker can cause denial of service in Fedify-based servers by triggering unbounded HTTP redirect loops during remote document resolution.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fedify\\/fedify","vendor":"fedify"},{"product":"fedify\\/vocab-runtime","vendor":"fedify"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Fedify is a TypeScript library for building federated server apps powered by ActivityPub. Prior to 1.9.6, 1.10.5, 2.0.8, and 2.1.1, @fedify/fedify follows HTTP redirects recursively in its remote document loader and authenticated document loader without enforcing a maximum redirect count or visited-URL loop detection. An attacker who controls a remote ActivityPub key or actor URL can force a server using Fedify to make repeated outbound requests from a single inbound request, leading to resource consumption and denial of service. This vulnerability is fixed in 1.9.6, 1.10.5, 2.0.8, and 2.1.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Fedify affected by resource exhaustion caused by unbounded redirect following during remote key/document resolution","id":"CVE-2026-34148","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":12,"n_references":5,"next":{"headline":"Coolify: Authenticated Host-Level RCE via Unescaped Database Credentials in Backup Jobs","id":"CVE-2026-34149"},"packages":[{"ecosystem":"npm","fixed":["1.9.6"],"introduced":["0"],"last_affected":[],"package":"@fedify/fedify","purl":null,"source":"GHSA-gm9m-gwc4-hwgp"},{"ecosystem":"npm","fixed":["1.9.6"],"introduced":["0"],"last_affected":[],"package":"@fedify/fedify","purl":"pkg:npm/%40fedify/fedify","source":"GHSA-gm9m-gwc4-hwgp"},{"ecosystem":"npm","fixed":["1.10.5"],"introduced":["1.10.0"],"last_affected":[],"package":"@fedify/fedify","purl":null,"source":"GHSA-gm9m-gwc4-hwgp"},{"ecosystem":"npm","fixed":["1.10.5"],"introduced":["1.10.0"],"last_affected":[],"package":"@fedify/fedify","purl":"pkg:npm/%40fedify/fedify","source":"GHSA-gm9m-gwc4-hwgp"},{"ecosystem":"npm","fixed":["2.0.8"],"introduced":["2.0.0"],"last_affected":[],"package":"@fedify/fedify","purl":null,"source":"GHSA-gm9m-gwc4-hwgp"},{"ecosystem":"npm","fixed":["2.0.8"],"introduced":["2.0.0"],"last_affected":[],"package":"@fedify/fedify","purl":"pkg:npm/%40fedify/fedify","source":"GHSA-gm9m-gwc4-hwgp"},{"ecosystem":"npm","fixed":["2.1.1"],"introduced":["2.1.0"],"last_affected":[],"package":"@fedify/fedify","purl":null,"source":"GHSA-gm9m-gwc4-hwgp"},{"ecosystem":"npm","fixed":["2.1.1"],"introduced":["2.1.0"],"last_affected":[],"package":"@fedify/fedify","purl":"pkg:npm/%40fedify/fedify","source":"GHSA-gm9m-gwc4-hwgp"},{"ecosystem":"npm","fixed":["2.0.8"],"introduced":["0"],"last_affected":[],"package":"@fedify/vocab-runtime","purl":null,"source":"GHSA-gm9m-gwc4-hwgp"},{"ecosystem":"npm","fixed":["2.0.8"],"introduced":["0"],"last_affected":[],"package":"@fedify/vocab-runtime","purl":"pkg:npm/%40fedify/vocab-runtime","source":"GHSA-gm9m-gwc4-hwgp"},{"ecosystem":"npm","fixed":["2.1.1"],"introduced":["2.1.0"],"last_affected":[],"package":"@fedify/vocab-runtime","purl":null,"source":"GHSA-gm9m-gwc4-hwgp"},{"ecosystem":"npm","fixed":["2.1.1"],"introduced":["2.1.0"],"last_affected":[],"package":"@fedify/vocab-runtime","purl":"pkg:npm/%40fedify/vocab-runtime","source":"GHSA-gm9m-gwc4-hwgp"}],"prev":{"headline":"Stored Cross-Site Scripting (XSS) via Configuration File Import on TP-Link's TL-SG108PE","id":"CVE-2026-34127"},"products":["fedify","vocab-runtime"],"published":"2026-04-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-07","vendors":["@fedify"]},"summary":"An attacker can cause denial of service in Fedify-based servers by triggering unbounded HTTP redirect loops during remote document resolution.","url":"https://insights.sbomify.com/CVE-2026-34148/"}