# CVE-2026-34148: Fedify affected by resource exhaustion caused by unbounded redirect following during remote key/document resolution

> An attacker can cause denial of service in Fedify-based servers by triggering unbounded HTTP redirect loops during remote document resolution.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Apr 2026
- **Updated:** 7 Apr 2026
- **Also known as:** GHSA-gm9m-gwc4-hwgp

## What is CVE-2026-34148?

CVE-2026-34148 is a high-severity denial of service vulnerability in @fedify fedify, published on 6 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fedify is a TypeScript library for building federated server apps powered by ActivityPub. Prior to 1.9.6, 1.10.5, 2.0.8, and 2.1.1, @fedify/fedify follows HTTP redirects recursively in its remote document loader and authenticated document loader without enforcing a maximum redirect count or visited-URL loop detection. An attacker who controls a remote ActivityPub key or actor URL can force a server using Fedify to make repeated outbound requests from a single inbound request, leading to resource consumption and denial of service. This vulnerability is fixed in 1.9.6, 1.10.5, 2.0.8, and 2.1.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-34148?

12 open source packages ship an affected version, including @fedify/fedify and @fedify/vocab-runtime. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@fedify/fedify` | npm | All versions | 1.9.6 |
| `@fedify/fedify` | npm | All versions | 1.9.6 |
| `@fedify/fedify` | npm | From 1.10.0 | 1.10.5 |
| `@fedify/fedify` | npm | From 1.10.0 | 1.10.5 |
| `@fedify/fedify` | npm | From 2.0.0 | 2.0.8 |
| `@fedify/fedify` | npm | From 2.0.0 | 2.0.8 |
| `@fedify/fedify` | npm | From 2.1.0 | 2.1.1 |
| `@fedify/fedify` | npm | From 2.1.0 | 2.1.1 |
| `@fedify/vocab-runtime` | npm | All versions | 2.0.8 |
| `@fedify/vocab-runtime` | npm | All versions | 2.0.8 |
| `@fedify/vocab-runtime` | npm | From 2.1.0 | 2.1.1 |
| `@fedify/vocab-runtime` | npm | From 2.1.0 | 2.1.1 |

Products: Fedify Fedify\/Fedify, Fedify Fedify\/Vocab-Runtime.

## How do I fix CVE-2026-34148?

Upgrade @fedify/fedify to a fixed version for your release line: 1.9.6, 1.10.5, 2.0.8 or 2.1.1.

## Is CVE-2026-34148 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34148 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34148 and fix it if it is affected.

What it is: CVE-2026-34148 is a high-severity denial of service vulnerability in @fedify fedify, published on 6 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34148 exists.

Affected packages and fixed versions:
- @fedify/fedify (npm): affected all versions; fixed in 1.9.6
- @fedify/fedify (npm): affected all versions; fixed in 1.9.6
- @fedify/fedify (npm): affected from 1.10.0; fixed in 1.10.5
- @fedify/fedify (npm): affected from 1.10.0; fixed in 1.10.5
- @fedify/fedify (npm): affected from 2.0.0; fixed in 2.0.8
- @fedify/fedify (npm): affected from 2.0.0; fixed in 2.0.8
- @fedify/fedify (npm): affected from 2.1.0; fixed in 2.1.1
- @fedify/fedify (npm): affected from 2.1.0; fixed in 2.1.1
- @fedify/vocab-runtime (npm): affected all versions; fixed in 2.0.8
- @fedify/vocab-runtime (npm): affected all versions; fixed in 2.0.8
- @fedify/vocab-runtime (npm): affected from 2.1.0; fixed in 2.1.1
- @fedify/vocab-runtime (npm): affected from 2.1.0; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34148/ (Markdown: https://insights.sbomify.com/CVE-2026-34148/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34148
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34148
- OSV: https://osv.dev/vulnerability/CVE-2026-34148

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34148/
Summaries are generated and may contain mistakes; the official description above is the record.
