CVE-2026-34154 Discourse has a subscription access bypass in its discourse-subscriptions plugin

Low 2.1 Published Updated

Attackers can bypass payment requirements to access subscription-gated groups in Discourse forums, requiring an upgrade to the latest version.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-34154?

CVE-2026-34154 is a low-severity vulnerability in Discourse Discourse, published on 19 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Discourse is an open-source discussion platform. In versions prior to 2026.1.4, 2026.3.1, 2026.4.1 and 2026.5.0-latest.1, a vulnerability in the discourse-subscriptions plugin allows users to gain access to subscription-gated groups without completing payment. This issue has been fixed in versions 2026.1.4, 2026.3.1, 2026.4.1 and 2026.5.0-latest.1.

Weakness: CWE-862

Which versions are affected by CVE-2026-34154?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions2026.1.4, 2026.3.1, 2026.4.1

Products include Discourse Discourse.

How do I fix CVE-2026-34154?

Upgrade discourse to a fixed version for your release line: 2026.1.4, 2026.3.1 or 2026.4.1.

Is CVE-2026-34154 being exploited?

There is no known exploitation of CVE-2026-34154 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2026-34154, GHSA-pjgj-7mjq-6j7g.

Is CVE-2026-34154 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free