# CVE-2026-34155: RAUC: Improper Signing of Plain Bundles Exceeding 2 GiB

> An integer overflow in RAUC allows attackers to modify unsigned portions of large update bundles, bypassing signature verification on embedded Linux systems.

- **Severity:** High 7.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:L/VI:H/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Mar 2026
- **Updated:** 31 Mar 2026
- **Also known as:** DEBIAN-CVE-2026-34155, GHSA-6hj7-q844-m2hx, UBUNTU-CVE-2026-34155

## What is CVE-2026-34155?

CVE-2026-34155 is a high-severity vulnerability in rauc, published on 31 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

RAUC controls the update process on embedded Linux systems. Prior to version 1.15.2, RAUC bundles using the 'plain' format exceeding a payload size of 2 GiB cause an integer overflow which results in a signature which covers only the first few bytes of the payload. Given such a bundle with a legitimate signature, an attacker can modify the part of the payload which is not covered by the signature. This issue has been patched in version 1.15.2.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature), CWE-196 (Unsigned to Signed Conversion Error)

## Which versions are affected by CVE-2026-34155?

It affects 1 product.


Products: Pengutronix Rauc.

## How do I fix CVE-2026-34155?

Upgrade to a fixed version.

## Is CVE-2026-34155 being exploited?

There is no known exploitation of CVE-2026-34155 in the wild and no public exploit code.

## Other vulnerabilities in rauc

- [CVE-2020-25860](https://insights.sbomify.com/CVE-2020-25860/): Race condition in Pengutronix RAUC (medium 6.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34155 and fix it if it is affected.

What it is: CVE-2026-34155 is a high-severity vulnerability in rauc, published on 31 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-34155 in the wild and no public exploit code.

Affected product: rauc. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34155/ (Markdown: https://insights.sbomify.com/CVE-2026-34155/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34155
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34155
- OSV: https://osv.dev/vulnerability/CVE-2026-34155

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34155/
Summaries are generated and may contain mistakes; the official description above is the record.
