# CVE-2026-34156: NocoBase Affected by Sandbox Escape to RCE via console._stdout Prototype Chain Traversal in Workflow Script Node

> Authenticated attackers can escape the JavaScript sandbox in NocoBase's workflow script node to execute arbitrary code with root privileges.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2026
- **Updated:** 2 Apr 2026
- **Also known as:** GHSA-px3p-vgh9-m57c

## What is CVE-2026-34156?

CVE-2026-34156 is a critical code injection vulnerability in nocobase, published on 31 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

NocoBase is an AI-powered no-code/low-code platform for building business applications and enterprise solutions. Prior to version 2.0.28, NocoBase's Workflow Script Node executes user-supplied JavaScript inside a Node.js vm sandbox with a custom require allowlist (controlled by WORKFLOW_SCRIPT_MODULES env var). However, the console object passed into the sandbox context exposes host-realm WritableWorkerStdio stream objects via console._stdout and console._stderr. An authenticated attacker can traverse the prototype chain to escape the sandbox and achieve Remote Code Execution as root. This issue has been patched in version 2.0.28.

Weakness: CWE-913 (Improper Control of Dynamically-Managed Code Resources)

## Which versions are affected by CVE-2026-34156?

2 open source packages ship an affected version, including @nocobase/plugin-workflow-javascript. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@nocobase/plugin-workflow-javascript` | npm | All versions | 2.0.28 |
| `@nocobase/plugin-workflow-javascript` | npm | All versions | 2.0.28 |

Products: Nocobase Nocobase.

## How do I fix CVE-2026-34156?

Upgrade @nocobase/plugin-workflow-javascript to 2.0.28 or later.

## Is CVE-2026-34156 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34156 exists.

Public exploit code:

- CVE-2026-34156 (github_poc): https://github.com/0xredash/CVE-2026-34156
- NocoBase  2.0.27 - VM Sandbox Escape (exploitdb)
- https://github.com/Dhananjayasj/CVE-2026-34156-NocoBase-Sandbox-Escape-via-Workflow-Execution-Vulnerability- (github_poc): https://github.com/Dhananjayasj/CVE-2026-34156-NocoBase-Sandbox-Escape-via-Workflow-Execution-Vulnerability-
- NocoBase - VM Sandbox Escape to Remote Code Execution (nuclei): http/cves/2026/CVE-2026-34156.yaml

## Other vulnerabilities in nocobase

- [CVE-2026-34825](https://insights.sbomify.com/CVE-2026-34825/): NocoBase Has SQL Injection via template variable substitution in workflow SQL node (high 8.5)
- [CVE-2026-41640](https://insights.sbomify.com/CVE-2026-41640/): NocoBase Vulnerable to SQL Injection via String Concatenation in Recursive Eager Loading (high 7.5)
- [CVE-2026-41641](https://insights.sbomify.com/CVE-2026-41641/): NocoBase Vulnerable to SQL Validation Bypass via `sqlCollection:update` Missing `checkSQL` Call (high 7.2)
- [CVE-2026-40346](https://insights.sbomify.com/CVE-2026-40346/): NocoBase has SSRF in Workflow HTTP Request and Custom Request Plugins (medium 6.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34156 and fix it if it is affected.

What it is: CVE-2026-34156 is a critical code injection vulnerability in nocobase, published on 31 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34156 exists.

Affected packages and fixed versions:
- @nocobase/plugin-workflow-javascript (npm): affected all versions; fixed in 2.0.28
- @nocobase/plugin-workflow-javascript (npm): affected all versions; fixed in 2.0.28

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34156/ (Markdown: https://insights.sbomify.com/CVE-2026-34156/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34156
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34156
- OSV: https://osv.dev/vulnerability/CVE-2026-34156

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34156/
Summaries are generated and may contain mistakes; the official description above is the record.
