# CVE-2026-34166: LiquidJS has a Memory Limit Bypass via Quadratic Amplification in `replace` Filter

> Attackers can bypass memory limits in LiquidJS via quadratic amplification in the replace filter, causing out-of-memory conditions.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Apr 2026
- **Updated:** 10 Apr 2026
- **Also known as:** GHSA-mmg9-6m6j-jqqx, MINI-mr79-63h7-2r8j, MINI-vr73-v232-qff5

## What is CVE-2026-34166?

CVE-2026-34166 is a low-severity denial of service vulnerability in harttle liquidjs, published on 8 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

LiquidJS is a Shopify / GitHub Pages compatible template engine in pure JavaScript. Prior to 10.25.3, the replace filter in LiquidJS incorrectly accounts for memory usage when the memoryLimit option is enabled. It charges str.length + pattern.length + replacement.length bytes to the memory limiter, but the actual output from str.split(pattern).join(replacement) can be quadratically larger when the pattern occurs many times in the input string. This allows an attacker who controls template content to bypass the memoryLimit DoS protection with approximately 2,500x amplification, potentially causing out-of-memory conditions. This vulnerability is fixed in 10.25.3.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-34166?

2 open source packages ship an affected version, including liquidjs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `liquidjs` | npm | All versions | 10.25.3 |
| `liquidjs` | npm | All versions | 10.25.3 |

Products: Liquidjs Liquidjs.

## How do I fix CVE-2026-34166?

Upgrade liquidjs to 10.25.3 or later.

## Is CVE-2026-34166 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34166 exists.

## Other vulnerabilities in harttle liquidjs

- [CVE-2026-30952](https://insights.sbomify.com/CVE-2026-30952/): liquidjs has a path traversal fallback vulnerability (high 8.7)
- [CVE-2026-35525](https://insights.sbomify.com/CVE-2026-35525/): LiquidJS has a root restriction bypass for partial and layout loading through symlinked templates (high 8.2)
- [CVE-2026-41311](https://insights.sbomify.com/CVE-2026-41311/): LiquidJS is vulnerable to Denial of Service via circular block reference in layout (high 7.5)
- [CVE-2026-33285](https://insights.sbomify.com/CVE-2026-33285/): LiquidJS: memoryLimit Bypass through Negative Range Values Leads to Process Crash (high 7.5)
- [CVE-2026-33287](https://insights.sbomify.com/CVE-2026-33287/): LiquidJS has Exponential Memory Amplification through its replace_first Filter $& Pattern (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34166 and fix it if it is affected.

What it is: CVE-2026-34166 is a low-severity denial of service vulnerability in harttle liquidjs, published on 8 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34166 exists.

Affected packages and fixed versions:
- liquidjs (npm): affected all versions; fixed in 10.25.3
- liquidjs (npm): affected all versions; fixed in 10.25.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34166/ (Markdown: https://insights.sbomify.com/CVE-2026-34166/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34166
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34166
- OSV: https://osv.dev/vulnerability/CVE-2026-34166

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34166/
Summaries are generated and may contain mistakes; the official description above is the record.
