# CVE-2026-34191: Apache Portable Runtime Utility: SQL Injection in apr_dbd_oracle

> SQL injection vulnerability in the apr_dbd_oracle provider allows attackers to manipulate database queries, potentially leading to unauthorized data access or modification.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2026
- **Updated:** 6 Aug 2026
- **Also known as:** ALPINE-CVE-2026-34191, BELL-CVE-2026-34191, BIT-apr-util-2026-34191, DEBIAN-CVE-2026-34191, ECHO-7cdd-31d1-19a0, GHSA-39fj-527g-2hph

## What is CVE-2026-34191?

CVE-2026-34191 is a critical SQL injection vulnerability in Apache Portable Runtime Utility, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Portable Runtime Utility via apr_dbd_oracle provider.

This issue affects Apache Portable Runtime Utility: from 1.6.0 through 1.6.3

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-34191?

1 open source package ship an affected version, including apr-util. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apr-util` | Bitnami | From 1.6.0 | 1.6.5 |

Products: Apache Apr-Util.

## How do I fix CVE-2026-34191?

Upgrade apr-util to 1.6.5 or later.

## Is CVE-2026-34191 being exploited?

There is no known exploitation of CVE-2026-34191 in the wild and no public exploit code.

## Other vulnerabilities in Apache Portable Runtime Utility

- [CVE-2009-2412](https://insights.sbomify.com/CVE-2009-2412/): Integer overflow in n/a (critical 10.0)
- [CVE-2026-32327](https://insights.sbomify.com/CVE-2026-32327/): Apache Portable Runtime Utility: apr-util XML stack recursion crash (critical 9.1)
- [CVE-2025-49506](https://insights.sbomify.com/CVE-2025-49506/): Apache Portable Runtime Utility: apr_password_validate() vulnerable to timing attack (high 7.5)
- [CVE-2026-34501](https://insights.sbomify.com/CVE-2026-34501/): Apache Portable Runtime Utility: Heap buffer overflow in APR redis client (high 7.5)
- [CVE-2026-34502](https://insights.sbomify.com/CVE-2026-34502/): Apache Portable Runtime Utility: Heap buffer overflow in APR memcached client (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34191 and fix it if it is affected.

What it is: CVE-2026-34191 is a critical SQL injection vulnerability in Apache Portable Runtime Utility, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34191 in the wild and no public exploit code.

Affected packages and fixed versions:
- apr-util (Bitnami): affected from 1.6.0; fixed in 1.6.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34191/ (Markdown: https://insights.sbomify.com/CVE-2026-34191/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34191
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34191
- OSV: https://osv.dev/vulnerability/CVE-2026-34191

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34191/
Summaries are generated and may contain mistakes; the official description above is the record.
