CVE-2026-34197 Apache ActiveMQ Improper Input Validation

Exploited in the wild High 8.8 Published Updated

Authenticated attackers can achieve remote code execution on Apache ActiveMQ brokers by exploiting Jolokia MBeans to load malicious Spring XML configurations.

Exploited in the wild
Since 16 Apr 2026
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-34197?

CVE-2026-34197 is a high-severity code injection vulnerability in Apache Activemq, published on 7 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ.

Apache ActiveMQ Classic exposes the Jolokia JMX-HTTP bridge at /api/jolokia/ on the web console. The default Jolokia access policy permits exec operations on all ActiveMQ MBeans (org.apache.activemq:*), including BrokerService.addNetworkConnector(String) and BrokerService.addConnector(String).

An authenticated attacker can invoke these operations with a crafted discovery URI that triggers the VM transport's brokerConfig parameter to load a remote Spring XML application context using ResourceXmlApplicationContext. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec().

This issue affects Apache ActiveMQ Broker: before 5.19.4, from 6.0.0 before 6.2.3; Apache ActiveMQ All: before 5.19.4, from 6.0.0 before 6.2.3; Apache ActiveMQ: before 5.19.4, from 6.0.0 before 6.2.3.

Users are recommended to upgrade to version 5.19.4 or 6.2.3, which fixes the issue

Weakness: CWE-78, CWE-94, CWE-20

Which versions are affected by CVE-2026-34197?

9 open source packages ship an affected version, including org.apache.activemq:activemq-all, activemq and org.apache.activemq:activemq-broker. It affects 2 products.

PackageAffectedFixed in
org.apache.activemq:activemq-all MavenAll versions5.19.5
org.apache.activemq:activemq-all MavenAll versions5.19.5
org.apache.activemq:activemq-all MavenFrom 6.0.06.2.3
org.apache.activemq:activemq-all MavenFrom 6.0.06.2.3
activemq BitnamiAll versions5.19.4, 6.2.3
org.apache.activemq:activemq-broker MavenAll versions5.19.5
3 more packages
org.apache.activemq:activemq-broker MavenAll versions5.19.5
org.apache.activemq:activemq-broker MavenFrom 6.0.06.2.3
org.apache.activemq:activemq-broker MavenFrom 6.0.06.2.3

Products include Apache Activemq, Apache Activemq Broker.

How do I fix CVE-2026-34197?

Upgrade org.apache.activemq:activemq-all to a fixed version for your release line: 5.19.5 or 6.2.3. US federal agencies must fix it by 30 Apr 2026.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-34197 being exploited?

Yes. Attackers have exploited CVE-2026-34197 in the wild since at least 16 Apr 2026.

Public exploit code: 1 Metasploit module, 1 Nuclei template and 14 proofs of concept on GitHub.

All Apache Activemq vulnerabilities

Sources

Also known as BIT-activemq-2026-34197, CLSA-2026-1790690736, DEBIAN-CVE-2026-34197, GHSA-rxpj-7qvf-xv32, MINI-45x5-qf32-c9vj, MINI-844g-gv3j-wwgm and 7 more.

Is CVE-2026-34197 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free